-   Linux - Software (
-   -   Unable to write to Samba Shares. (

usaf_sp 11-02-2005 11:24 AM

Unable to write to Samba Shares.
I have been searching and searching for a solution to my problem, but have been unable to find an answer.

I have been unable to properly configure Samba to act like a workgroup computer similar to WinXP. This is my set up:

3 computers. 1 Linux, 2 WinXP. All are connected via a wireless LinkSys router. Obviously Samba is installed on the Linux (SuSE 10) machine. Simple File Sharing is enabled on the WinXp computers.

This is the problem:

I can access all shares on all computers throughout the network. I can write from WinXP to WinXP shares and from Linux to WinXP. WinXP is unable to write to the Samba Shares, but can read and copy the files. When I try to write to the Samba Shares, the WinXP system gives the following error:

"Cannot Copy Samba+HOWTO-Collection: Cannot find the specified file. Make sure you specify the correct path and file name."

I am unsure what could be the problem so here is my smb.conf file:


# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2005-09-13
        workgroup = MSHOME
        printcap name = cups
        cups options = raw
        map to guest = Bad User
        include = /etc/samba/dhcp.conf
        logon path = \\%L\profiles\.msprofile
        logon home = \\%L\%U\.9xprofile
        logon drive = P:
        add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
        domain master = No
        restrict anonymous = no
        netbios name = TMDC
        max protocol = NT
        ldap ssl = No
        server signing = Auto
        case sensitive = no
        guest ok = yes
        msdfs proxy = no
        read only = no
        domain logons = No
        security = user

## Share disabled by YaST
# [homes]
#        comment = Home Directories
#        valid users = %S
#        browseable = No
#        read only = No
#        inherit acls = Yes

## Share disabled by YaST
# [profiles]
#        comment = Network Profiles Service
#        path = %H
#        read only = No
#        store dos attributes = Yes
#        create mask = 0600
#        directory mask = 0700

## Share disabled by YaST
# [users]
#        comment = All users
#        path = /home
#        read only = No
#        inherit acls = Yes
#        veto files = /aquota.user/groups/shares/

## Share disabled by YaST
# [groups]
#        comment = All groups
#        path = /home/groups
#        read only = No
#        inherit acls = Yes

        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No

        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @ntadmin root
        force group = ntadmin
        create mask = 0664
        directory mask = 0775

        inherit acls = yes
        path = /home/shared/Network 2/

[software archive]
        inherit acls = yes
        path = /home/shared/Network 1/

## Share disabled by YaST
# [netlogon]

Can you see anything that does not look right? Perhaps I tried to set up a small simple network wrong, in that case what would be the proper steps?

Any help you could provide will be greatly appreciated.

usaf_sp 11-02-2005 01:45 PM

I got it to work.

I deleted my smb.conf file and used swat to generate a new one. I then went and changed the permissions of the folders that I wanted to write to.

The main problem was the permissions. Dumb mistake. Sorry to waste everyone's time.

All times are GMT -5. The time now is 04:45 AM.