LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-29-2018, 07:02 AM   #1
jb47
LQ Newbie
 
Registered: Jun 2018
Posts: 7

Rep: Reputation: Disabled
Unable to send email through Bugzilla software


When configuring Email on Bugzilla am getting the following error
Quote:
"Can't locate object method "quit" via package "Net::SMTP::SSL" at Bugzilla/Config/Common.pm line 370."
All the required Perl Nodules and Net::SMTP::SSL are installed and up-to date.

perl 5, version 16, subversion 3 (v5.16.3)
Net::SMTP::SSL is up to date (1.04)

Any idea to resolve this?
 
Old 08-30-2018, 04:41 PM   #2
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,376

Rep: Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550
Have you reviewed the troublshooting steps at the bugzilla documentation?
https://bugzilla.readthedocs.io/en/5...install-config
 
Old 09-04-2018, 11:16 AM   #3
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
postfix, exim, or other MTA installed?
how does this host process mail outside of Bugzilla?
 
Old 09-10-2018, 04:08 AM   #4
jb47
LQ Newbie
 
Registered: Jun 2018
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Habitual View Post
postfix, exim, or other MTA installed?
how does this host process mail outside of Bugzilla?
I have defined MTA mail server details on /etc/mail.rc and have tested with few mail services like mailx and mail. Am able to send email through these services.

But when I configure the same on Bugzialla and click on save button it give the error
Quote:
"Can't locate object method "quit" via package "Net::SMTP::SSL" at Bugzilla/Config/Common.pm line 370."
I have reinstalled the Net::SMTP::SSL and also verified my configuration with but nothing help me here.

Last edited by jb47; 09-10-2018 at 04:09 AM.
 
Old 09-10-2018, 12:15 PM   #5
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,376

Rep: Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550Reputation: 1550
Quote:
If all those things don't help, activate the smtp_debug parameter and check your webserver logs.
What happened when you did that?
 
Old 09-10-2018, 12:19 PM   #6
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Yawnstown, Ohio
Distribution: Mojave
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by jb47 View Post
I have defined MTA mail server details on /etc/mail.rc and have tested with few mail services like mailx and mail. Am able to send email through these services.
Those aren't "services" those are client programs/utilities.

/etc/mail.rc <--- sendmail or postfix?

2.2.3. checksetup.pl

"Next, rerun checksetup.pl. It reconfirms that all the modules are present, and notices the altered localconfig file, which it assumes you have edited to your satisfaction. It compiles the UI templates, connects to the database using the 'bugs' user you created and the password you defined, and creates the 'bugs' database and the tables therein."
says https://www.bugzilla.org/docs/2.20/h...iguration.html

How did you re-install those modules?
"Rerun the CPAN commands (or manual compile) using the full path to Perl from the top of checksetup.pl. This will make sure you are installing the modules in the right place." says this.

Your "goto" resource should should be https://www.bugzilla.org/docs/2.20/html/index.html
Bugzilla version?
OS version?
perl version?

You haven't provided much for us to go on.
Is this a new install of Bugzilla or an upgrade? Perhaps a clean start (do over) is necessary?

Nothing help me here either

"rerun checksetup.pl" is the only action I could find for you.
It likely won't "fix" it, but it may provide clues.

Last edited by Habitual; 09-10-2018 at 12:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable to send email with attachment clearfell Linux - Desktop 11 11-27-2017 03:49 PM
sendmail is unable to get access to the outside world? unable to send email? cyberdome Linux - Server 25 04-02-2014 11:40 AM
Unable to send email from Sendmail rridler Linux - Software 26 07-13-2006 02:23 PM
Unable to send/receive email newlinuxgeek Linux - Software 2 01-10-2005 10:07 AM
Unable to send or receive email dcroxton Linux - Networking 0 04-29-2004 08:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration