LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   unable to resolve hostname (https://www.linuxquestions.org/questions/linux-software-2/unable-to-resolve-hostname-638886/)

edgjerp 04-30-2008 08:58 AM

unable to resolve hostname
 
for some reason I am unable to do anything that requires sudo, as my computer is unable to resolve my host name. one thread said to change hostname to localhost, but that requires sudo, which does not work...

any idea what to do?

camorri 04-30-2008 10:17 AM

As I understand Ubuntu's way of allowing sudo, a user must have 'administrative rights' for sudo to work.

I don't know who set the system up, but you may need to talk to an administrator to get the privileges. If you installed it yourself, then you have several choices.

It is possible to enable the root login in Ubuntu. It is not recommended on their web site however. If you are the only user of the system, then that may not be a bad idea.

You can create a new account with Admin privilges, and then use sudo.

Here is a link to help you out.

https://help.ubuntu.com/community/RootSudo

edgjerp 04-30-2008 10:58 AM

I installed the system, and should thus have the right permissions, being the only user configured.

the problem is that sudo itself does not work, I do not get a message telling me that I lack permissions. if I could just get root permissions once, I could reset the hostname, and hopefully fix the problem.

tredegar 04-30-2008 11:18 AM

Select "Rescue mode" AKA "Single user mode" from the grub boot menu.
You will be logged into a terminal as root.
Edit your hosthame.
Reboot with:
shutdown -r now

edgjerp 04-30-2008 11:42 AM

thanks, that worked

tredegar 04-30-2008 05:28 PM

Quote:

thanks, that worked
Excellent.
And thanks for the follow-up.
:)


All times are GMT -5. The time now is 03:05 AM.