LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-16-2007, 10:52 PM   #1
paganinipro
LQ Newbie
 
Registered: Dec 2006
Location: USA
Distribution: Debian Etch Linux Kernel 2.6.18 AMD64X
Posts: 13

Rep: Reputation: 0
Unable to install samba


Hello!

I tried to install Samba via Synaptic and it failed reporting an error that my software index was broken and recommended running apt-get -f install.

I ran that through the terminal and it came out with the following:

Preparing to replace samba 3.0.24-6etch4 (using .../samba_3.0.24-6etch9_amd64.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: warning - old pre-removal script returned error exit status 102
dpkg - trying script from the new package instead ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: error processing /var/cache/apt/archives/samba_3.0.24-6etch9_amd64.deb (--unpack):
subprocess new pre-removal script returned error exit status 102
Errors were encountered while processing:
/var/cache/apt/archives/samba_3.0.24-6etch9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I searched around and even after finding that this problem is sometimes remedied by dpkg --configure -a, that still didn't work.

From what I see, which is very little, it looks like the old package is creating the problem. Would anyone have any insight into how I can remedy this problem?

Thanks!

P.S. I also tried running apt-get remove on samba, which also failed producing the same errors.
 
Old 12-17-2007, 11:15 AM   #2
tyggna
LQ Newbie
 
Registered: Jul 2007
Posts: 14

Rep: Reputation: 0
After remove

You could try an apt-get clean command--that'll delete the old package file as well. Chances are that it's with a configuration file, if you find that and delete it, that should fix the problem--I don't know where samba stores it's configuration files, though.
 
Old 12-23-2007, 02:36 PM   #3
paganinipro
LQ Newbie
 
Registered: Dec 2006
Location: USA
Distribution: Debian Etch Linux Kernel 2.6.18 AMD64X
Posts: 13

Original Poster
Rep: Reputation: 0
I tried everything with apt.
apt-get -f upgrade
apt-get clean
apt-get update
etc., etc.

Nothing seems to be working though. I do get this error however.

Preparing to replace samba 3.0.24-6etch4 (using .../samba_3.0.24-6etch9_amd64.deb) ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: warning - old pre-removal script returned error exit status 102
dpkg - trying script from the new package instead ...
invoke-rc.d: dangling symlink: /etc/rc2.d/K09samba
dpkg: error processing /var/cache/apt/archives/samba_3.0.24-6etch9_amd64.deb (--unpack):
subprocess new pre-removal script returned error exit status 102
Errors were encountered while processing:
/var/cache/apt/archives/samba_3.0.24-6etch9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Of course this happens only with the samba package. And I naturally can't uninstall it whatsoever until this bug is fixed.

I'm going to search the net and post if I found a fix for it, but would anyone else have an idea?

Thanks!
 
Old 12-23-2007, 03:33 PM   #4
complich8
Member
 
Registered: Oct 2007
Distribution: rhel, fedora, gentoo, ubuntu, freebsd
Posts: 104

Rep: Reputation: 16
error message says "dangling symlink" ...

I'd recommend removing /etc/rc2.d/K09samba and trying again.
 
Old 12-24-2007, 02:20 AM   #5
paganinipro
LQ Newbie
 
Registered: Dec 2006
Location: USA
Distribution: Debian Etch Linux Kernel 2.6.18 AMD64X
Posts: 13

Original Poster
Rep: Reputation: 0
Worked perfectly!

Thanks so much for all the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new to samba - unable to connect PerfectReign Linux - Networking 2 08-02-2005 04:31 PM
unable to unmount samba meenaxi Linux - Networking 2 12-03-2004 03:48 AM
unable to print through Samba beowulf405 Linux - Newbie 4 07-03-2004 08:45 PM
Unable to do the Samba LinuxBlackBox Linux - Software 0 05-20-2004 03:25 PM
Unable to configure samba aroop Linux - Networking 3 05-08-2004 04:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration