LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-23-2011, 12:28 PM   #1
amritpalpathak
Member
 
Registered: Feb 2010
Posts: 116

Rep: Reputation: 15
Unable to install any package in ubuntu (10.04)


When i try to insall any package in ubuntu (10.04),it gives the error message .suppose i am installing vlc it gives

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
gstreamer0.10-plugins-bad: Depends: libflite1 but it is not going to be installed
vlc: Depends: vlc-nox (= 1.0.6-1ubuntu1.8) but it is not going to be installed
Depends: libqtcore4 (>= 4:4.6.1) but it is not going to be installed
Depends: libqtgui4 (>= 4:4.6.1) but it is not going to be installed
Depends: libsdl-image1.2 (>= 1.2.5) but it is not going to be installed
Depends: libtar but it is not going to be installed
Depends: libvlccore2 (>= 1.0.0~rc1) but it is not going to be installed
Depends: libxcb-keysyms1 (>= 0.3.6) but it is not going to be installed
Recommends: vlc-plugin-pulse (= 1.0.6-1ubuntu1.8) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).



Then i did .

sudo apt-get -f install


It too gives the error as:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
libflite1
The following NEW packages will be installed:
libflite1
0 upgraded, 1 newly installed, 0 to remove and 429 not upgraded.
1 not fully installed or removed.
Need to get 0B/7,274kB of archives.
After this operation, 10.6MB of additional disk space will be used.
Do you want to continue [Y/n]? y
E: Invalid archive signature
E: Prior errors apply to /var/cache/apt/archives/libflite1_1.3-release-2build1_i386.deb
debconf: apt-extracttemplates failed: Bad file descriptor
dpkg-deb: `/var/cache/apt/archives/libflite1_1.3-release-2build1_i386.deb' is not a debian format archive
dpkg: error processing /var/cache/apt/archives/libflite1_1.3-release-2build1_i386.deb (--unpack):
subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
/var/cache/apt/archives/libflite1_1.3-release-2build1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Please somebody help me to fix it.

Thanks

amritpalpathak.blogspot.com
 
Old 07-23-2011, 04:09 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,316

Rep: Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578
May be the package libflite1_1.3-release-2build1_i386.deb is corrupt ?

Suggest : Delete /var/cache/apt/archives/libflite1_1.3-release-2build1_i386.deb

Then update your repositories : sudo apt-get update
( Can be done before any attempt to install a package, or at least every time there
is a problem with 'unmet dependencies' or "package is not going to be installed".)


... And hopefully you can now install vlc + dependencies.

.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install python-dev package on 64-bit Ubuntu Linux MahendraL Linux - Newbie 2 05-24-2011 07:05 PM
unable to install package on Ubuntu smartgupta Linux - Software 2 11-04-2010 08:43 AM
Unable to install package roni_atx Linux - General 3 11-18-2008 04:41 PM
Unable To Install a Package carlosinfl Debian 3 07-02-2008 05:56 PM
Unable to install package DaveyB Debian 3 10-29-2006 04:25 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration