LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-25-2006, 02:22 PM   #1
akkaplan@verizon.net
LQ Newbie
 
Registered: Apr 2006
Posts: 2

Rep: Reputation: 0
unable to create new folder on usb drive


I am running Linux 4.0 on a Toshiba Laptop with a one-partition hard drive, Windows XP Home, and two external usb 2.0 disks. I load Linux from the CD and it recognizes all the drives. I click on the laptop hard drive and one of the external drives, set all the preferences to read-write and remove the read only check in the device tab, and then try to create a new folder on the usb drive by clicking the Edit tab and then the create new folder tab. I get the naming box, put in WinBack and click ok. I then get a message saying "could not make folder mnt/ubb1/winback." My goal is to copy a bunch of files from the C Drive (the laptop hard drive) to the external drive. Thank you. Alan
 
Old 04-25-2006, 02:32 PM   #2
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
It could be a permissions thing. As it being a live CD means you can't edit the inittab, try doing the whole thing as root.
 
Old 04-25-2006, 02:56 PM   #3
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Remember that if the external drive is formatted using NTFS, then it is read-only. Suppose that it is fat32; take a look at the "man mount" manpage. If you open up a console, and su to root, you can use the "remount" option to change the mount options. For example, you could use "umask=000" or if your username is akkaplan, you could use the "uid=akkaplan" option.

Last edited by jschiwal; 04-25-2006 at 03:17 PM.
 
Old 04-26-2006, 10:47 AM   #4
akkaplan@verizon.net
LQ Newbie
 
Registered: Apr 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for the responses. A clarification: I'm running Knoppix 4.0 on the laptop and trying to create the new folders using Konqueror desktop. I don't know whether this changes anything. Sorry for the confusion. I'm completely new to Linux and the terminology is still pretty baffling.
 
Old 04-26-2006, 11:05 AM   #5
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Open up a console and type 'su' to get into root. As root, make a folder you want to mount your usb drive, then make it writable for the user you want to give access:
Code:
#mkidr /mnt/usbdrive
#chown <username> /mnt/usbdrive
then open up your /etc/fstab in a text editor and make sure the line that mounts this drive is correct, if there is none, add it.
Code:
/dev/sda1   /mnt/usbdrive   vfat   users,defaults,umask=000   0   0
this assumes a) your usb drive is fat32 (ntfs is read only), and b) the device name to your disk is /dev/sda1. Usb hard disks are usually called by this name but you can do 'fdisk -l' to be sure.

You can then issue the command 'mount /mnt/usbdrive' to mount it. Anything you save to this folder will be stored on the usb drive. If you don't want it to automatically mount at boot time, add the line 'noauto' to the options.

regards,
...drkstr

Last edited by drkstr; 04-26-2006 at 11:06 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
help! unable to mount usb-drive ! ag2uki Debian 14 09-29-2006 03:38 AM
I DID IT! (But....) Can't create folder on FAT-32 drive JesusFreak84 Linux - Newbie 5 02-16-2006 08:47 PM
Unable to write to external USB drive m_lp_ql_m Linux - Newbie 2 08-29-2005 03:21 PM
How to create bootable USB flash drive EStester Linux - Enterprise 7 05-19-2005 06:35 PM
how can i default the max folder file size when it create inside a folder antony_csf Linux - Software 1 06-17-2004 02:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration