-   Linux - Software (
-   -   "Unable to create context rendering" error whet run OpenGL application (

Rodnower 04-04-2010 11:05 AM

"Unable to create context rendering" error whet run OpenGL application
I try to run Mesa gears example and I get following error:

freeglut (./gears): Unable to create direct context rendering for window 'Gears'
This may hurt performance.

though the application runs successfully, but I guess that in future I will have much problems with productivity.

I run Linux CentOS 5 on WMvare 7. Mesa's version is 6.5
Relevant output of lspci -v gives:

00:0f.0 VGA compatible controller: VMware SVGA II Adapter (prog-if 00 [VGA controller])
        Subsystem: VMware SVGA II Adapter
        Flags: bus master, medium devsel, latency 64, IRQ 9
        I/O ports at 10d0 [size=16]
        Memory at d0000000 (32-bit, non-prefetchable) [size=128M]
        Memory at d8000000 (32-bit, non-prefetchable) [size=8M]
        [virtual] Expansion ROM at 30000000 [disabled] [size=32K]
        Capabilities: [40] Vendor Specific Information

Any one have idea? There is driver of vmvare for CentOS?
Thank you for ahead.

Rodnower 04-04-2010 12:35 PM

So, like I understood, while I run Linux on VMware, this error isn't significant. The solution is to install Linux on host, and then it will own direct access to graphic card.

All times are GMT -5. The time now is 03:22 AM.