LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-19-2016, 02:08 AM   #1
ForumBot
LQ Newbie
 
Registered: Jul 2016
Posts: 25

Rep: Reputation: Disabled
Unable to connect to d-bus when starting X server


I get an error when attempting to start an X server as root on my Arch Linux x86_64 laptop by executing startx with no arguments.

The stderr output is here. The content of /usr/share/X11/xorg.conf.d is here. The content of .xinktrc is here.

I have read through the Arch Linix Wiki on The X server modify and reset .xinitrc, and updated my system, to no avail.
 
Old 07-26-2016, 07:55 AM   #2
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,912

Rep: Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513
Usually you need to specify the display... specially if an X server is already running.
 
Old 07-26-2016, 11:24 PM   #3
ForumBot
LQ Newbie
 
Registered: Jul 2016
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jpollard View Post
Usually you need to specify the display... specially if an X server is already running.
Thank you for the response, jpollard.

How can I go about learning how to specify the display?

I know hardly anything about graphics, and I did not see anything about it in the Xorg Arch Linux Wiki page. My graphics card is Intel Corporation HD Graphics 5500 (rev 9).

I tried following the WikiHow article on on, but running Xorg -configure produced this error. The contents of the log file /var/log/Xorg.0.log are this.

Last edited by ForumBot; 07-26-2016 at 11:53 PM. Reason: Added more sweet deets
 
Old 07-27-2016, 06:17 AM   #4
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,912

Rep: Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513Reputation: 1513
I just use something like "startx :11"

The 11 is just to get away from any default GUI that may be active. :4 or :5 should also work. On my system :0, :1, or :2 won't work as these have been/are used by the GUI login. If there is NO GUI active at all, startx without parameters SHOULD use :0.

The configure error should be due to either the device chosen (:0) is in use and can't be accessed. Normally, no "xorg.conf" file is required.
 
Old 07-29-2016, 01:10 PM   #5
ForumBot
LQ Newbie
 
Registered: Jul 2016
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by jpollard View Post
I just use something like "startx :11"

The 11 is just to get away from any default GUI that may be active. :4 or :5 should also work. On my system :0, :1, or :2 won't work as these have been/are used by the GUI login. If there is NO GUI active at all, startx without parameters SHOULD use :0.

The configure error should be due to either the device chosen (:0) is in use and can't be accessed. Normally, no "xorg.conf" file is required.
I tried startx :n, for n going from 0 to 5 inclusive and 11, but they all gave the identical error as the one I originally got when using startx, other than the time and date being different.

More details: dbus-daemon is indeed running. Also, I am not using any GUI; I am typing commands directly in the console and lack a desktop environment.

Last edited by ForumBot; 07-29-2016 at 01:47 PM.
 
Old 08-03-2016, 02:28 AM   #6
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 3,795
Blog Entries: 1

Rep: Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263
Have you tried startx without any .xinitrc?

I don't have any Arch installations, but I have lots of openSUSE, Fedora, Mageia, Debian, Mint, Kubutu and a few other distros, and IIRC, on none that have an Xorg that works at all and has the required FOSS Xorg video driver installed, will startx not start a session as root without the necessity of specifying a display - unless a DM greeter is active. In that case I don't remember how many will abort and how many will automatically use the next available display. I'm pretty sure it happens both ways. Normally on machines other than my 24/7 boxen I boot without starting any DM/greeter, so use startx a lot. For startx to work as a normal user, usually I find that /usr/bin/Xorg has wrong permissions, and I need to chmod 4711. Could it be that Arch (or systemd) has done something regarding permissions to prevent startx from working as root? For as long as I can remember I've been seeing repeated that it is "dangerous" to run Xorg as root.
 
1 members found this post helpful.
Old 08-04-2016, 12:53 AM   #7
ForumBot
LQ Newbie
 
Registered: Jul 2016
Posts: 25

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
Have you tried startx without any .xinitrc?

I don't have any Arch installations, but I have lots of openSUSE, Fedora, Mageia, Debian, Mint, Kubutu and a few other distros, and IIRC, on none that have an Xorg that works at all and has the required FOSS Xorg video driver installed, will startx not start a session as root without the necessity of specifying a display - unless a DM greeter is active. In that case I don't remember how many will abort and how many will automatically use the next available display. I'm pretty sure it happens both ways. Normally on machines other than my 24/7 boxen I boot without starting any DM/greeter, so use startx a lot. For startx to work as a normal user, usually I find that /usr/bin/Xorg has wrong permissions, and I need to chmod 4711. Could it be that Arch (or systemd) has done something regarding permissions to prevent startx from working as root? For as long as I can remember I've been seeing repeated that it is "dangerous" to run Xorg as root.

Running it without an xinitrc fixed the problem. Any idea why?
 
Old 08-04-2016, 03:45 AM   #8
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE 24/7; Debian, Knoppix, Mageia, Fedora, others
Posts: 3,795
Blog Entries: 1

Rep: Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263Reputation: 1263
Quote:
Originally Posted by ForumBot View Post
Running it without an xinitrc fixed the problem. Any idea why?
~/.xinitrc AFAICT is a superceding file, not a merge file, whose existence means global xinitrc is ignored entirely, and thus it needs to be equally complete, and valid.

Last edited by mrmazda; 08-04-2016 at 03:48 AM.
 
1 members found this post helpful.
Old 08-04-2016, 05:11 AM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,137
Blog Entries: 1

Rep: Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873Reputation: 873
Your .xinitrc is too complex and lacked the wm/de as far as I could tell. Keep it simple.

# mv .xinitrc .zinitrc
# echo "exec jwm" > .xinitrc
# startx -- :11 -depth 24 -dpi 100 -nolisten tcp -to 10 -layout MultiHead

That other stuff might be better served in .Xdefaults or .Xresources. Or manually run after starting X.
 
2 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NFS/NIS: startup hangs at "Starting system message bus..." after switching server hardware kikinovak Slackware 6 06-08-2016 10:17 AM
Unable to connect MS SQL server 2008 Remote Server through SQUID proxy server samank75 Linux - Server 5 01-19-2012 10:19 PM
FC5 ---message bus -initialization --x server not starting narendra.pant Fedora 4 09-19-2006 06:47 AM
unable to connect to X server schneidz Linux - Software 18 08-24-2006 12:22 PM
Suddenly unable to connect to my web server and my ftp server. HELP! Silly22 Linux - Software 4 05-23-2004 05:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration