LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-30-2008, 05:41 PM   #1
KrazyKanuk
Member
 
Registered: Sep 2007
Location: St. Catharines, Ontario
Distribution: Slackware 15/64 bit
Posts: 139

Rep: Reputation: 15
ucspi-ssl-0.70


I am trying to compile ucspi-ssl-0.70 that I got from http://www.superscript.com/ucspi-ssl/ but every time I do I get the following errors:
Code:
sh print-ccperl.sh > ccperl
./compile `cat ccperl` sslperl.c
sslperl.c: In function ‘server’:
sslperl.c:41: warning: initialization discards qualifiers from pointer target type
sslperl.c:96: warning: passing argument 4 of ‘Perl_call_argv’ discards qualifiers from pointer target type
rm -f perlembed.lib
sh print-ldperl.sh > perlembed.lib
./load sslperl auto_cafile.o auto_ccafile.o auto_cadir.o auto_dhfile.o \
        auto_certfile.o auto_keyfile.o auto_ciphers.o rules.o remoteinfo.o \
        timeoutconn.o sslhandle.o cdb.a ssl.a unix.a cdb.a unix.a  `cat \
        socket.lib` `cat ssl.lib` `cat socket.lib` `cat perlembed.lib`
/usr/bin/ld: cannot find -lperl
collect2: ld returned 1 exit status
make: *** [sslperl] Error 1
compile: fatal: cannot make it-base it-sslperl
nflnx1:/package/host/superscript.com/net/ucspi-ssl-0.70#
I have tried this both with and without patching with the same results. I can't seem to find where or how to fix this. If anyone can help on this matter it would be greatly appreciated.
 
Old 07-30-2008, 07:16 PM   #2
KrazyKanuk
Member
 
Registered: Sep 2007
Location: St. Catharines, Ontario
Distribution: Slackware 15/64 bit
Posts: 139

Original Poster
Rep: Reputation: 15
Found the problem, I was missing the libperl-dev package installed this and all went well

Last edited by KrazyKanuk; 07-30-2008 at 09:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error making ucspi-tcp hobz Linux - Server 1 11-13-2009 01:35 PM
creating an SSL page under non SSL site with apache1.33? taiwf Linux - Software 1 06-27-2006 01:06 AM
SSL Connections / second and SSL Accelerator Cards on Linux LinuxGeek Linux - Networking 0 06-10-2006 08:18 AM
ucspi patching issues rh9 ewlnxnewB Programming 0 11-27-2003 02:44 AM
ucspi-tcp patch problem (rh9) for qmail install ewlnxnewB Linux - Software 2 11-27-2003 12:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration