-   Linux - Software (
-   -   Ubuntu 10.04: GRUB bootloader crashes (

matrix13 05-06-2010 10:32 PM

Ubuntu 10.04: GRUB bootloader crashes
I have a Dell Studio 14 laptop with Windows 7 64bit preinstalled. The processor is core i5 and the machine has 4GB RAM. I freed 25GB of memory from my Hard disk and tried to install Ubuntu 10.04 (AMD). Everything went fine. I restarted and Logged into Ubuntu. It worked like a charm. Then I restarted to Windows7. This also worked well as expected.

But, when I rebooted again, I got a black screen saying that
“No modules found. Press any key to restart”
When I press a key, it says “No operating system found”, probably after checking through a network (it printed lines starting with PXE).

I tried exactly in the same way with Ubuntu 8.04 in my machine, and this worked without any problem. The Bootloader was not corrupted after restarting from Windows. I noticed the problem with Ubuntu 9.10 and 10.04. I feel like a problem regarding the bootloader version. AFAIK, 9.10 and 10.04 is using GRUB 2 when 8.04 use the old version of GRUB.

Is there any way to resolve this issue?
Thanks and Regards

AlucardZero 05-07-2010 08:08 AM

Reseat your hard drives and wires. If that doesn't work, try booting from a live CD and reinstalling grub from it (ask Google how).

matrix13 05-11-2010 12:24 PM

Mine is a Dell laptop. I dont know how to reset my hard drives and wires.

I reinstalled the grub2 from ubuntu 10.04 live cd using the 'grub-install' command. Everything worked fine. But when I booted into windows 7 and restarted my machine, again the grub is lost.

Any help??

bundacia 05-14-2010 06:07 PM

me too =(
I've got the same setup and have the same problem. Installed Ubuntu 10.04 alongside windows. Worked great. But as soon as I boot windows it messes up the mbr somehow and I get the same error message. grub-install fixed it for me too, but only until the next time I boot windows.

matrix13 05-15-2010 12:14 AM

I couldn't solve the problem.
So, I removed GRUB2 and installed the legacy GRUB instead. Now its working fine. But you will not be able to use the new features from GRUB2.

This link might be helpful to you.

colorpurple21859 05-15-2010 07:54 AM

Did you run updates before reinstalling grub2?

akihitotan1984 06-08-2010 09:56 AM

it's dell datasafe software
check the link i attached.
I had the same problem.

I'd been using super grub to boot...temporary solution..
have not fix it yet

akihitotan1984 06-08-2010 09:57 AM

attached an url to the problem....from ubuntu forum

All times are GMT -5. The time now is 04:22 PM.