-   Linux - Software (
-   -   Two million error lines in .xsession-error file from FireFox (

acanton 08-27-2005 04:09 PM

Two million error lines in .xsession-error file from FireFox
I run Kanotix with KDE 3.4 and Firefox. I notieced that my ~ .xsession-errors was HUGE and contained 2 million lines of code all in sets like below.

After some experimentation I find that it is ouput from Firefox. Anyone know how to stop it? I've symlinked the errors file to /dev/null but would like to know WHY this is happening.



(Gecko:3547): Gdk-CRITICAL **: gdk_pixbuf_get_from_drawable: assertion `gdk_window_is_viewable (src)' failed

(Gecko:3547): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_n_channels: assertion `pixbuf != NULL' failed

(Gecko:3547): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_bits_per_sample: assertion `pixbuf != NULL' failed

(Gecko:3547): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(Gecko:3547): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

(Gecko:3547): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_rowstride: assertion `pixbuf != NULL' failed

(Gecko:3547): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

foo_bar_foo 08-27-2005 04:58 PM

are you running firefox binary uninstalled from within the source tree or something ?

acanton 08-27-2005 09:59 PM


Originally posted by foo_bar_foo
are you running firefox binary uninstalled from within the source tree or something ?
No, this is the plain, old, vanilla Firefox .deb file from the Sid (unstable) repos installed via Synaptic. Zillions of people must use this version (i.e. all the Mepis, Kanotix, and other Debian flavors that track Sid) so I can't figure out what's going on. Looks like I need one of the libpixbuf files but not sure which one!


foo_bar_foo 08-28-2005 12:31 AM

lets see

(gary) /usr/lib  $ objdump -t | grep gdk_pixbuf_get_width
00003dc6 g    F .text  0000006f              gdk_pixbuf_get_width
(gary) /usr/include/gtk-2.0  $ grep -R gdk_pixbuf_get_from_drawable ./
./gdk/gdkpixbuf.h:GdkPixbuf *gdk_pixbuf_get_from_drawable (GdkPixbuf  *dest,

looks like just basic gtk2 stuff

i have seen similar reports periodically from various gtk apps and i think it has to do with the theme you are using. seems like i remember some qt type theme ?
i remember you said you were using KDE -- if your gtk apps are using your KDE theme
that's not normal so it's a cool hack your os builders have done.

i guess if it's not slowing stuff down it's ok to ignore it

acanton 08-28-2005 10:53 AM

Thank you. Yes, I'm using the gtk-engine-qt via the KDE Control Panel to give some of my gtk apps a nice look.... specifically Synaptic and Jpilot. I didn't know that FireFox would be effected such that it spews out rendering errors so often.

I wonder if the FireFox folks know about this?


EDIT: SOLVED (SORT OF). I find that when I change the gtk style in the KDE Control screen (for GTK Styles and Fonts.... you only have this if you installed the gtk engine) to Garmik the problem goes away and no errors are written. I was using 'Qt' and that causes errors as does setting it to blank.

I should know better than to try to mix KDE with Gnome stuff. Just asking for trouble.

All times are GMT -5. The time now is 05:36 AM.