LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-26-2004, 08:10 PM   #1
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Rep: Reputation: 0
Turning off systems sounds in Red Hat/Gnome


So, our system admin recently upgraded our machines to Red Hat 9, and in the process managed to somehow re-enable system sounds.

The problem for me is that the idiot (or possibly sadist) who programmed the software I use daily decided that every time I click the mouse I get a confirmation BEEP. Yes, that's right. Every time. It's driving me nuts.

In my provious installation I somehow managed to turn off the system sound, but that was 1.5 years ago....

So, how do I turn off the system sound? As far as I know, it doesn't have a sound card. I've tried going through the Gnome preferences, but without any luck.

I don't want ANY sound coming from this machine. It's for work - I DON'T WANT TO BE DISTURBED. Please help.

thanks.
 
Old 03-26-2004, 08:36 PM   #2
phantomgraph
LQ Newbie
 
Registered: Feb 2004
Location: MI
Distribution: Red Hat 5.0+ & Fedora
Posts: 16

Rep: Reputation: 0
Ditching System sounds.

Your Sysem admin isn't the BOFH bofh.ntk.net/Bastard.html Simon is he? =)

Sounds like you have to go into the system setings (or mixer) and turn down the volume level of the PC speaker. I had something like this when I hit one too many backspaces in the terminal and I drove me nuts untill I lowered the volume for the speaker.

Good luck, hope this helps.
 
Old 03-26-2004, 08:41 PM   #3
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Nah, my sysad is a decent guy with to many computers and too little time... But this is driving me insane.

I can't change the mixer volume, cause there is no mixer installed. when I try I get the error message "unable to open audio device '/dev/mixer/' .

Should the mixer actually change the PC spekaer settings as well?
 
Old 03-26-2004, 09:16 PM   #4
phantomgraph
LQ Newbie
 
Registered: Feb 2004
Location: MI
Distribution: Red Hat 5.0+ & Fedora
Posts: 16

Rep: Reputation: 0
Well,

Quote:
Nah, my sysad is a decent guy with to many computers and too little time... But this is driving me insane.
!Simon = good }:8>

Quote:
I can't change the mixer volume, cause there is no mixer installed. when I try I get the error message "unable to open audio device '/dev/mixer/' .
Well, with no mixer, the only options I can think of are to disable system sounds in your desktop theme. If that fails either get your system admin to install the mixer so you can control the PC speaker volume level or use the screwdriver approach and crack the case and unplug the speaker from the motherboard.

Quote:
Should the mixer actually change the PC speaker settings as well?
It has on my RH boxes for a long time, but to be honest I haven't messed with a linux box without a sound card in about four years.
 
Old 03-26-2004, 09:53 PM   #5
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Original Poster
Rep: Reputation: 0
already disabled sounds, doesn't help.
I've talked to the sysad already, and he doesn't want to fix it "because it would be a personal customization".

since he was the one who didn't setup the computer properly I disagree with that assessment, but I haven't pressed the issue yet...

In an unrelated issue, this computer insists on revving up the fan to max power for about 20 seconds every minute, and since I can't seem to change the fan speed on this linux garbage the only option is to demand my old machine back. Hopefully this will take care of the mixer as well...

Gaaah, I hate Linux so much.
 
Old 03-26-2004, 11:17 PM   #6
phantomgraph
LQ Newbie
 
Registered: Feb 2004
Location: MI
Distribution: Red Hat 5.0+ & Fedora
Posts: 16

Rep: Reputation: 0
Quote:
Originally posted by CyberGnu
already disabled sounds, doesn't help.
I've talked to the sysad already, and he doesn't want to fix it "because it would be a personal customization".

since he was the one who didn't setup the computer properly I disagree with that assessment, but I haven't pressed the issue yet...
Pull the speaker wire then. Takes about 3 minutes.

Quote:
Originally posted by CyberGnu
In an unrelated issue, this computer insists on revving up the fan to max power for about 20 seconds every minute, and since I can't seem to change the fan speed on this linux garbage the only option is to demand my old machine back. Hopefully this will take care of the mixer as well...
If this is the same physical machine as you had previously, you might be able to play around with apm (advanced power management) either in Linux (I don't remember if it has any setting for fans - they are usually controlled by the motherboard) or Most likely by disabling it in BIOS. (It should make the fan run all the time.)

Quote:
Originally posted by CyberGnu
Gaaah, I hate Linux so much.
Note the sig }:8>
 
Old 03-26-2004, 11:41 PM   #7
Pwnz3r
Member
 
Registered: Jan 2004
Location: Lancaster, OH
Distribution: Gentoo
Posts: 393

Rep: Reputation: 30
You're bitching about problems with Linux that are actually hardware problems. Stop being a dumbass and listen up.

First of all, UT2004 crashes on my comp sometimes but when it crashed on my bro's Windows XP box Windows gave him the magical blue screen and shutdown. For me, it just goes to my desktop like I exited. Yeah, Linux sucks. (major sarcasm)

To say a little more, my PC speaker ticked me off and it had nothing to do with Linux. That's why I got off my lazy ass and took a minute or so to unscrew my thumbs screws and take it out of my case.

Getting pissed off at Linux for hardly even trivial matters is quite rediculous. You can blame Linux for hardware problems, but in the end you'll just be a dumbass and not the guy that worked for free to help produce the GNOME interface so that you could sit down and enjoy Linux graphically. Would you rather pay lots of money for crap that crashes and never works quite right? Alright, go back to Windows and leave us out of it.

The point is that you're blaming the wrong thing here. It might have absolutely nothing to do with the GNOME desktop enviroment, Linux, the expresso machine, or whatever else you want to blame, but instead it might have something to do with the fact that this is a new machine to you and obviously it's not going to mirror the other hardware.

It's quite stupid to enter Linux Forums and call Linux a piece of crap when it's more than likely the hardware's fault because PC speakers are annoying no matter what OS you use. Getting pissed at an entire OS over something so easy to solve is just pitiful. I hope you can see how much you're overreacting about this thing.
 
Old 03-27-2004, 06:55 AM   #8
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Original Poster
Rep: Reputation: 0
phantomgraph: Thanks. I hesitate on opening the machine quite yet - while I might enjoy wathcing my sysad turn beet red I doubt I'll ever get help again....

The thing is, the speaker issue isn't a hardware problem.

bear with me here: My previous machine ran Red Hat 7 / KDE. My new machine is running Red Hat 9, and Gnome as the default session.

when I first asked my sysad about the sound issue, he suggested logging in to the KDE desktop instead of Gnome. I did, and found that the sound was turned off. Magical. Unfortunately, the graphics were royally screwed up in KDE.

Back to sysad, who suggests that I'd delete all my old .KDE files. Said and done, relogging in to KDE, about half the graphics are fixed, but now the sounds are back.

So apparently there IS a software setting somewhere, and I was hoping someone here would know what it could be...

In regards to the apm: do you have any idea where/how to access it? Not same machine, this one is about 50% faster than the old one, but since the fans aren't in use for about 60% of the time I should be able to run them contantly at a lower speed.

I'll try messing with the BIOS when this current calculation is done.

and again, thanks!


Pwnzr: read above. And while you're at it: http://bash.org/?152037
no offense to phantom, but what he suggested earlier didnt seem to help, and I was hoping to troll someone else in.

So, now that you are here, how about displaying some of that marvelous intellect and tell me how to disable the system sounds?
 
Old 03-27-2004, 07:09 AM   #9
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Hey, phantomgraph, I managed to solve my sound problem while searching for fan speed adjustements!

Turns out that the BIOS has a speaker option that I simply turned off.

No luck on the fan speed, though. But hey, one out of two, that ain't bad!

Gnu
 
Old 03-27-2004, 09:51 AM   #10
phantomgraph
LQ Newbie
 
Registered: Feb 2004
Location: MI
Distribution: Red Hat 5.0+ & Fedora
Posts: 16

Rep: Reputation: 0
Sound and Fan Issues

Quote:
Originally posted by CyberGnu
Hey, phantomgraph, I managed to solve my sound problem while searching for fan speed adjustements!

Turns out that the BIOS has a speaker option that I simply turned off.
Kewl! I have to admit thou that I've never had a computer with a BIOS setting for the PC speaker, but my BIOS does have settings for APM(ON of, power down after idle, crap like that.) I always turn the darn thing off.

Quote:
Originally posted by CyberGnu
No luck on the fan speed, though. But hey, one out of two, that ain't bad!

Gnu
Knowing what I know about hardware design on motherboards, it sounds a lot like your new computer has a temperature sensor that activates and deactivates the fan as needed. I had a friend who's computer did that. Again the only way I know of to fix it (if it's not in the BIOS) is to do a little hardware modification. You might have to go so far as hardwiring the fan into the power supply or disassembling the power supply and wire the fan to the outputs if it's the fan in the power supply that's kicking on and off.

I've also never heard of a fan in a computer that operates at multiple voltage (multiple speeds) ,although because their all DC I see no reason why they couldn't. As far as I know their either ON or OFF. You might want to check up on the manufacturers web site thou just in case you missed something in the BIOS. (Might want to look for anything like overheat or CPU cooling.)

I wish I could be more of a help on that, but if it were my computer I would just install XMMS and don a pair of headphones and a goofy grin. }:8>
 
Old 03-31-2004, 03:18 AM   #11
CyberGnu
LQ Newbie
 
Registered: Mar 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Phantom, thanks again

Not about to open up the machine yet - it's sealed by the sysad and breaking the seal would incur the wrath of one of the two people you should never piss off...

What is XMMS? And sadly, I AM wearing headphones... But the fan is actually louder - roughly as loud as my Roomba...

Multiple fan speeds are pretty common - most new motherboards come with fan control options, such as Asus Q-fan. (although the point of the Q-fan is to set the fan speed to depend on the heat loud - to set it to a constant value you have to tinker with it a bit). Independent software solutions ar pretty rare - almost exclusively used by overclockers who have realized that after they revved up their machine the fans are so loud that they couldn't sleep with the machine in their bedrooom. That's essentially what I was asking for in another thread on this board, but no takers...

There are other solutions like Zalmans controller, where you can control the fan speed manually, but that would again force me to break the seal.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
turning a firwall off in red hat 9 berrance Linux - Software 4 08-21-2004 10:16 AM
How to chat between two systems connected in a LAN.I use Red hat linux 9. LIN_MINDS Linux - Newbie 0 03-04-2004 07:37 AM
Red hat file systems alexr186 Linux - Software 5 10-10-2003 07:29 PM
Turning off login/logout sounds in mandrake 9.1 & playing flash. Moses420ca Linux - Newbie 1 07-15-2003 10:59 AM
Newbie with question on partitioning linux red hat file systems... marvc Linux - Networking 2 03-14-2003 05:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration