-   Linux - Software (
-   -   Trying to install xfce4-panel-menu (

dodle 07-13-2008 10:42 PM

Trying to install xfce4-panel-menu
Hello, I am trying to install xfce4-panel-menu but having a lot of problems. The first thing I tried was downloading the source .tar.gz and converting that to a .deb package with alien. After I install the .deb package there is still no option for it in "Add Items to the Panel".

After that didn't work, I searched for a repository and found the following:

deb testing main
deb-src testing main
From synaptic I try to install but says that it has some dependencies that aren't going to be installed. So I try to install the dependencies first and it tells me that it is going to uninstall xfce4 and the rest of my desktop.

So the last thing I tried was compiling from the source .tar.gz. Everything goes fine until I use the "make" command. It says "make: *** No targets specified and no makefile found. Stop."

Does anybody have a solution for me. I would really like to have xfce4-panel-menu over the regular xfce4-menu.

Here is a picture of what it looks like:

MS3FGX 07-14-2008 02:53 PM

First off, you can't directly convert a source package to an installable Debian package. Actually, let me rephrase that, you can; but the Debian package will still just be a source package, not a binary package which is what you want.

As for make failing, it is hard to say, but the error message would indicate you aren't in a directory that contains any Makefiles, so perhaps you need to navigate to a /src directory inside the extracted archive.

Finally, maybe it is different for Debian, but I always though the panel menu was part of the XFCE distribution. I know it has always been included and enabled in Slackware, and Slackware almost always sticks to the stock configuration from the developer, which would lead me to believe you should already have it.

dodle 07-14-2008 04:08 PM

Well my Xfce4 desktop did come with xfce4-menu, which is the default menu, but I found xfce4-panel-menu which is different.

I also tried converting an .rpm package to .deb, but that had the same effect.

The Readme that came with the source gives these instructions for installation:


make install (as root)

dodle 07-14-2008 04:20 PM

Nope, I've tried to a "make" from all folders with the directory and it doesn't work an any. Also there is no source directory.

All times are GMT -5. The time now is 07:53 PM.