-   Linux - Software (
-   -   Truecrypt Permissions (

dauphinfay 02-12-2009 06:03 PM

Truecrypt Permissions
Let me start by stating that I have already searched the forums and found nothing helpful for this situation. Everything mentioned has not worked. Here is what I did (probably for the worse).

I created a volume under OS X and now I can mount it under linux but cannot write to it. All of the chmod suggestions previously mentioned on serves to break truecrypt and force me to reinstall it. I realise that I could sudo nautilus but there has to be a better solution....recently accomplished. Any help would be appreciated. Thanks. :)

JulianTosh 02-12-2009 10:56 PM

#1: What version of TrueCrypt are you using to a) create the truecrypt volume on OS X, and b) open the volume on linux.

#2: chmoding to get proper permissions in the truecrypt volume shouldn't break truecrypt install, which leads me to believe you're improperly applying the chmod permissions. Can you give us an example of the chmod commands you've tried?

#3: What is the filesystem inside truecrypt volume?

dauphinfay 02-13-2009 06:57 AM

#1) I am using 6.1a for linux and that was also the version I used to create the volume under OS X.

#2) There were several options that I have read and tried. They don't matter as I have reinstalled it after breaking it. By "breaking it" I mean that truecrypt would no longer start from the gui (didn't try cli).

#3) The volume is HFS Extended - pretty much the standard for OS X.

Thanks for asking for clarification. I should have specified earlier regardless of how late it was for me.

All times are GMT -5. The time now is 01:18 AM.