-   Linux - Software (
-   -   Truecrypt 5.0 install problems. (

checkmate3001 02-07-2008 12:49 AM

Truecrypt 5.0 install problems.
First I had issues with gzip... but after downloading the tarball again that seems to have solved itself.

Now I have problems building and compiling:

downloaded wxWidgets source (all) 2.8.7


make WX_ROOT=/usr/src/wxWidgets-2.8.7 wxbuild
Produces warning:

/usr/src/wxWidgets-2.8.7/src/gtk/gsockgtk.cpp:134: warning: ‘wxDummyGsockVar’ defined but not used
I ignore it and do:

This produces errors...

StringConverter.h:23: error: ‘static std::wstring TrueCrypt::StringConverter::FromNumber(long int)’ cannot be overloaded
StringConverter.h:22: error: with ‘static std::wstring TrueCrypt::StringConverter::FromNumber(TrueCrypt::int64)’
StringConverter.h:26: error: ‘static std::wstring TrueCrypt::StringConverter::FromNumber(TrueCrypt::uint64)’ cannot be overloaded
StringConverter.h:25: error: with ‘static std::wstring TrueCrypt::StringConverter::FromNumber(long unsigned int)’
make[1]: *** [Buffer.o] Error 1
make: *** [all] Error 2
Anyone else have these errors or success compiling on debian amd-64?
I would have downloaded the ubuntu .deb (isn't it just debian anyways?)
but it is i386 so won't install.

Thank you in advance.

Truecrypt has been a thorn in my side for the last week (pre 5.0) so I don't expect it to work... unless I have windows or a non 64bit proc. Neither of those are acceptable options for me. I think I must be doing something wrong...

checkmate3001 02-07-2008 01:37 AM

Things this clueless man has tried:
(more for my notes)

removing g++ while keeping g++-4.1 ----> g++ isn't around so make doesn't work. (wonder what g++-4.1 is - patch?)
installing fuse2, libfuse2 and libfuse-dev ----> No change for 'make'... however 'make clean' doesn't complain about fuse not existing anymore.

I'm gonna try some sleep now... perhaps it will work in the morning like my problem with gzip... ;)

Heinzelotto 02-07-2008 07:21 PM

in this thread i've posted a patch and a complete .deb for ubuntu to use truecrypt under 64-bit linux.

checkmate3001 02-08-2008 12:10 AM

Thank you, but...

I end up with a lot of unmet dependencies...


dpkg: dependency problems prevent configuration of truecrypt:
truecrypt depends on libatk1.0-0 (>= 1.13.2); however:
Version of libatk1.0-0 on system is 1.12.4-3.
truecrypt depends on libc6 (>= 2.6-1); however:
Version of libc6 on system is 2.3.6.ds1-13etch4.
truecrypt depends on libfuse2 (>= 2.6); however:
Version of libfuse2 on system is 2.5.3-4.4.
truecrypt depends on libgcc1 (>= 1:4.2.1); however:
Version of libgcc1 on system is 1:4.1.1-21.
truecrypt depends on libglib2.0-0 (>= 2.14.0); however:
Version of libglib2.0-0 on system is 2.12.4-2.
truecrypt depends on libgtk2.0-0 (>= 2.12.0); however:
Version of libgtk2.0-0 on system is 2.8.20-7.
truecrypt depends on libpango1.0-0 (>= 1.18.3); however:
Version of libpango1.0-0 on system is 1.14.8-5.
truecrypt depends on libstdc++6 (>= 4.2.1); however:
Version of libstdc++6 on system is 4.1.1-21.
truecrypt depends on libxdamage1 (>= 1:1.1); however:
Version of libxdamage1 on system is 1:1.0.3-3.
truecrypt depends on libxrandr2 (>= 2:1.2.0); however:
Version of libxrandr2 on system is 2:
dpkg: error processing truecrypt (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
I've upgraded all I can (stable). Perhaps I should go unstable...

I'll see what I can do.

Thanks tho.

checkmate3001 02-08-2008 12:40 AM

Wait... I just found the patch...

Heinzelotto 02-08-2008 12:47 AM


Originally Posted by checkmate3001 (Post 3049866)
I end up with a lot of unmet dependencies...

since i built this version on ubuntu and since ubuntu is based on the unstable branch of debian, many of those packages are not yet availiable in such new versions in the stable-branch of debian.
I made another package without those dependencies:
md5sum: ecae7e5966d13e12121cc3289cec5202

checkmate3001 02-08-2008 12:53 AM

Well it seemed to compile fine... then I got this at the end:


/usr/bin/ld: unrecognized option '--hash-style=sysv'
/usr/bin/ld: use the --help option for usage information
collect2: ld returned 1 exit status
make[1]: *** [truecrypt] Error 1
make: *** [all] Error 2
I think I'm gonna give up for now...

checkmate3001 02-08-2008 12:55 AM

I'll give it one more shot...

checkmate3001 02-08-2008 01:07 AM

Nah... More problems.

Installs just fine, but when I run truecrypt I get:


truecrypt: /usr/lib/ version `FUSE_2.6' not found (required by truecrypt)
truecrypt: /lib/ version `GLIBC_2.4' not found (required by truecrypt)
I went unstable to install the packages, but it wants to remove a bunch of packages and install a bunch - I'm not messing with my server that much.

I'll just wait it out or find something else.

Thank you for all your help tho. I appreciate it.

checkmate3001 02-08-2008 10:35 AM

The truecrypt forums are up and running again. I posted a shortened version of this thread on there. I mentioned your help and said that it was on the ubuntu forums, but did not link to the ubuntu forums. I didn't want to step on any toes.

Thank you again for all your help. I will continue to try... I'm just really frustrated and disappointed - so I need a breather.

Andy_in_Qatar 03-25-2008 01:22 PM

Debian and Truecrypt 5 - yes, it does work. And the GUI looks just like it does in Windows - well almost. Drives are refered to as number 1 to 32 instead of by letter but that is fine. Was it easy? Well yes and no. I struggled and gave up but came across a kind Guru who eventually sorted it. He cursed and swore but says that now he has done it it is not actually too difficult. He is writing up the notes and I will send them out as soon as I get them. In the mean time do not despair. It is worth the wait.

brother.sand 03-27-2008 02:07 PM

Andy, let us know when you get this. I have the same problem as checkmate3001 and would really like to see what your guru did to get around the dependency problem.


jobsworth 11-27-2011 05:25 AM

64 bit debian squeeze - truecrypt is ok
32 bit debian squeeze - truecrypt needs sudo apt-get install libfuse-perl
or error message is cannot find

Yes moderator I know that this thread has not been replied to in over 6 months
but I came here looking for the answer but did not find it so others will too.
Only trying to be helpful.

All times are GMT -5. The time now is 12:25 AM.