LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-24-2002, 06:36 AM   #1
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Rep: Reputation: 0
Arrow Trouble with GRUB


I just made a clean install of RedHat Linux 7.3 and choose GRUB as my boot-whateveritscalled....

When I boot up, choose it will search for boot records on HDA-1 (in the bios) I get something like:

Searching for boot record..... Ok!
GRUB

and right after GRUB I got an input marker (blinking box or something like that), but it doesn't respond to any input at all... I've tried to modify the grub.conf and removed the option of booting into windows (which I can control via the BIOS instead) and make it timeout on 3 seconds and default on Linux, but I still cannot get past it...

Any tips or tricks? Maybe I can just scrap GRUB in some easy (??) way and make it just boot into RH right away as I can choose in the bios what HDD to select the boot record from, HDA-0 gives me Windows and HDA-1 gives me Linux...

Thanks in advance for any help....
 
Old 05-24-2002, 09:45 AM   #2
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
Make your 'menu.lst' file and place it in /boot/grub, then

% grub-install /dev/fd0

should do it for a floppy. If that works and grub boots from the floppy, then grub is working properly.

Try that first.

Bert
 
Old 05-24-2002, 10:57 AM   #3
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
Where exactly did you install GRUB? hda or hda1? And what is "choose it"?
 
Old 05-24-2002, 11:03 AM   #4
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Putting the GRUB boot stuff on a floppy worked just fine... with the floopy in my drive it booted perfectly, no problems at all...

So, back to the original problem... the "choose it" was odd written by me.. I apologize... I'll try again:

hda0 holds WinXP and bootchooser for WinXP/Win2k.
hda1 holds Linux and grub, and during install I selected some option about "putting boot *something* first on the /boot partition (I think that was it)" which would be required if I wanted to dualboot with NT, and since both XP and 2000 is NT based I figured that'd be the right thing to do...

Hope that clears it out some... otherwise I'll try again... And please don't flame me for running both XP and 2000... I'm trying to convert myself gradually and hopefully I'll end up running Linux for most stuff and XP for gaming...
 
Old 05-24-2002, 11:44 AM   #5
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
Dual and triple booting is O.K. -- as long as you use 2 or 3 Linuxes !!

But seriously, it sound like you boot to the W2K boot.ini menu which gives you the option to further boot to Windoze or whatever else is in boot.ini such as Linux. There are some How-Tos and mini-How-Tos that tell exactly what is required, but what happens is that boot.ini has to have some image that it can use to perform the next step. It sounds like boot.ini doesn't know where to find the Grub instructions. You might check the Linux Documentation Project (http://www.linuxdoc.org/), and look into the How-Tos on multi-booting.
 
Old 05-24-2002, 12:18 PM   #6
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by jglen490
It sounds like boot.ini doesn't know where to find the Grub instructions. You might check the Linux Documentation Project (http://www.linuxdoc.org/), and look into the How-Tos on multi-booting.
Well, I know it doesn't... thing is.. when I change some BIOS settings I get as far as to a "GRUB" promt (even tho graphical mode was selected) and a blinking inputmarker... But I get no respons from my keyboard at all... and even tho I got a 3sec delay and Linux selected as default, nothing happends.
 
Old 05-24-2002, 03:56 PM   #7
jglen490
Member
 
Registered: Apr 2002
Location: The next brick house on the right.
Distribution: Kubuntu 8.04
Posts: 668

Rep: Reputation: 31
It may be that your BIOS settings and boot.ini and Grub are fighting each other. If you can, please display the contents of your boot.ini and Grub menu.lst files here. We may be able to figure out how to get you going. Just hang in there !
 
Old 05-24-2002, 05:51 PM   #8
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks... they come a bit down here... Just wanted to say I'm not in a panic mode as Bert's solution lets me boot Linux. It's just a floppy to be inserted instead of a bios setting to be changed or another selection from my Windows bootup menu...

Anyway... here goes.

Quote:
boot.ini

[boot loader]
timeout = 8
default = multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS = "Microsoft Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT = "Microsoft Windows 2000 Professional" /fastdetect
ack... cannot read anything on my boot floppy from Windows (which I currently happened to be running )... So, I'll just reboot in a min and I'll post the menu.lst from Linux instead.... sorry for any inconvieniece
 
Old 05-24-2002, 05:57 PM   #9
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
menu.lst
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdb4
# initrd /initrd-version.img
#boot=/dev/hdb1
default=0
timeout=3
splashimage=(hd1,0)/grub/splash.xpm.gz
title linux (2.4.18-3)
root (hd1,0)
kernel /vmlinuz-2.4.18-3 ro root=/dev/hdb4 hdd=ide-scsi
initrd /initrd-2.4.18-3.img
This is the same one I got on the floppy (i.e. unedited after I made the floppy as Bert suggested above).
 
Old 05-27-2002, 08:03 AM   #10
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
Personally, I only use a floppy to boot. I use Windo$e Me on my first partition.

The boot sector is one place Windows never like to share ever since MS got rid of real dos mode. As you probably found out SilverSnake, booting from a GRUB floppy is pretty quick and will save only 2 or 3 seconds if GRUB was on the hard drive. That's a time penalty I'm happy to accommodate personally.

Just a thought if the hassle gets to yer.

Bert
 
Old 05-27-2002, 09:43 AM   #11
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Well, floopy it seems to be as no one seems to know how to solve the harddrive boot problem I got anyway... *shrugs* don't really mind it... Thanks Bert.
 
Old 05-28-2002, 05:40 AM   #12
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
SilverSnake, are you trying to use xp's or w2k's boot loader to boot linux?

If you installed grub on the hdb1 ( /boot ) partition, you need to make a copy of its boot sector and copy it to either xp's or w2k's partition. Then add an entry for linux in your boot.ini file.

If you are trying to use your bios to boot linux, you should have grub installed in the mbr of hdb.
 
Old 05-28-2002, 10:32 AM   #13
SilverSnake
LQ Newbie
 
Registered: May 2002
Location: Linköping, Sweden
Distribution: RedHat 7.3
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by linuxcool
SilverSnake, are you trying to use xp's or w2k's boot loader to boot linux?
Right now it's XPs boot loader that's in the mbr of my primary master disk.

Quote:
Originally posted by linuxcool
If you installed grub on the hdb1 ( /boot ) partition, you need to make a copy of its boot sector and copy it to either xp's or w2k's partition. Then add an entry for linux in your boot.ini file.

If you are trying to use your bios to boot linux, you should have grub installed in the mbr of hdb.
I did install grub on the hdb1 (/boot) partition and I try to boot Linux via Bios... but I do get as far as seeing a prompt-like thing saying "GRUB", but I cannot type anything and the computer stops there. But you still think I'd manage if I added a "link" to the GRUB in XP's boot loader? (I found how to do that in another topic but figured it wasn't worth it unless I got it to work with booting Linux with bios' help).

I'll try it out later then... Thanks for the idea!
 
Old 05-29-2002, 05:08 AM   #14
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
I think I see how you have it set up on hdb. You installed grub in the /boot ( hdb1 ) partition. The mbr has the original code in it and hdb1 is marked bootable. You then use your bios to boot from hdb instead of hda. But, you are having a problem getting it to boot. The grub disk you made works fine. Maybe you need to reinstall grub to hdb1. Just boot into linux and as root run
grub-install /dev/hdb1. Also, make sure that hdb1 is marked as bootable by using linux's fdisk. Then try it.
 
Old 12-05-2002, 04:14 PM   #15
bmiller
LQ Newbie
 
Registered: Dec 2002
Posts: 2

Rep: Reputation: 0
I know this is an old thread BUT....
I just loaded Linux on my XP system on the B drive and had the EXACT same problem.
- when tring to launch grub from the NT loader I just get a blank screen with "GRUB" in the upper left and a flashing cursor -

Simple fix: Go into the CMOS and add the second drive!!

Ha, I could access the second drive from Windows as well as Install and boot Linux (from the floppy) without ever having added the drive to the CMOS.

I only though about it when DOS fdisk would only see one drive.

From my NT loader I boot
-WinME
-XP
-Win 2k Server
-Windows Recovery Console
-Linux (redhat 8)

Just thought I'd add a little closure to this thread....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub Trouble RedNovember Linux - Software 13 02-20-2006 11:09 PM
GRUB trouble laubster Linux - General 2 01-05-2005 04:47 AM
Trouble with GRUB technician Linux - Software 5 02-16-2004 11:37 PM
Grub trouble p1az Linux - General 4 10-03-2003 01:20 PM
Grub trouble mcm8327 Linux - General 2 07-04-2003 09:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration