-   Linux - Software (
-   -   trouble using wine + 2-cd sets "cannot eject volume" (

beeblequix 10-28-2007 03:19 PM

trouble using wine + 2-cd sets "cannot eject volume"
I have a number of windows based games that i wish to run under wine but running into a snag.

I'm trying to install Guild Wars. I've first downloaded the gwsetup.exe, opened a gnome terminal, sudo wine gwsetup.exe, completed the first disk install. It now tells me "Please insert disk 2 <ok>". I try to eject the disk on the tower and it reads "Cannot eject volume. An application is preventing the volume 'Guild Wars Disc 1' from being ejected." I try to use Nautilus to *eject* the disk and it gives me the same error. I opened a terminal and tried to umount it "sudo umount /cdrom" and "sudo umount /media/cdrom0" but it just laughed at me.

What am I doing wrong? Why can't I eject the first disk? I've had the same problem last night with CoD and likely will see it with JK3. Any help appreciated. Thanks.

beeblequix 10-28-2007 04:01 PM

Found it.

wine eject n:

where n is the name of the optical drive. My system has two opticals so it would either be d: or e:.

beeblequix 10-29-2007 05:53 PM

Mmmkay, maybe someone else has had this issue too --

After CoD disk 1 was finished installing it asks for disk 2. From a terminal I typed "wine eject d:". "drive d:" ejected, I removed the disk and replaced it with disk 2. I loaded the disk and here's where it doesn't work. The disk from Nautilus appears to be there because I can read the new disk label "CoD2". But there aren't any files. What am I doing wrong? Do I have to remount the filesystem or something?

beeblequix 11-01-2007 09:42 AM

I found a bunch of Loki installers that takes care of the majority of these troubles. Call of Duty single and multiplayer work great. :)

beeblequix 11-02-2007 09:16 AM

How do I run Wine?

Wine is not something you run, you run applications with it. Simply open your applications and Wine should be loaded to run them automatically. You can configure your wine environment by running winecfg, and you can browse your fake windows drive at ~/.wine/drive_c

If you would like a general overview and tutorial about using Wine, you can read the User Guide. For the most part, however, Wine should be as straightforward as clicking the application you'd like to run from your Gnome/KDE/Whatever menu.

When using the terminal there are two valid methods of running applications. The first method is to chdir into the program's folder and then run the application directly, e.g.

cd "~/.wine/drive_c/Games/Tron" && wine tron.exe

The second method should ONLY be used if you are intending to install from something which has multiple CDs (you need to use this method to allow you to swap discs) as it doesn't always work. It consists in using the full Windows path like so...

wine "C:\Games\Tron\tron.exe"

Do NOT run with the full Linux path i.e. "wine /stuff/mygame.exe" or by double clicking icons from your file manager (sometimes this works but more often it will fail with errors of some sort).

This is because Wine passes this path as-is to the windows program in argv[0]. This is exactly what cmd.exe does and Wine has extensive tests for that. However some programs expect fully qualified windows path in argv[0], and break if they don't get it. Lots of programs written with Borland tools will have that problem because Borland mistakenly stated in the manuals that argv[0] will always be set to fully qualified path of the executable. Which is not the case.

If you use Gnome, KDE or XFCE4, then after you have installed some applications in Wine you should notice a Wine subfolder in your main desktop menu with menu entries for all your installed Wine programs (as long as you told them to make Start Menu shortcuts). If any apps seem to be missing try running "wineboot" and looking again.

All times are GMT -5. The time now is 01:44 AM.