-   Linux - Software (
-   -   trouble using 'gwhere' file catalog (

SaintDanBert 02-06-2012 02:22 PM

trouble using 'gwhere' file catalog
I admit to being a loose nut in the operator's chair, but can someone tell me what I'm missing about using gwhereGWhere Package Page?

Other than import from existing data files, I don't see how one loads information into the utility? Is it supposed to scan "drives" or "folder trees" to collect contents into the file catalog?

I have external, usb-connect drives (both flash and spinning), stacked like cord wood and want to catalog all of the contents.
GWhere looks like the ticket to get me started, but I cannot discover how to scan a drive or folder tree.

If one is supposed to obtain these lists of drive or folder contents form some other source, how does one do that?

The following find command approximates the data that I want to store:

prompt$ find /some/path/ -type f -printf "%U:%G; %M; %kK; %h; %f; acc=%AD-%AT; chg=%CD-%AT \n"

1000:1000; -rw-rw-r--; 0K; /some/path; baz; acc=02/06/12-11:48:55.3913852050; chg=02/06/12-11:48:55.3913852050
1000:1000; -rw-rw-r--; 0K; /some/path; bam; acc=02/06/12-11:48:12.1355528140; chg=02/06/12-11:48:12.1355528140
1000:1000; -rw-rw-r--; 0K; /some/path; bar; acc=02/06/12-11:48:12.1355528140; chg=02/06/12-11:48:12.1355528140
1000:1000; -rw-rw-r--; 0K; /some/path; foo; acc=02/06/12-11:48:12.1355528140; chg=02/06/12-11:48:12.1355528140

(NOTE -- I used the tags "acc" and "chg" so my brain keeps things sorted. I won't use them in the catalog database.)

I don't need the fractional seconds part of the time, but the format, "%AT" from find, that I used being lazy, shows them. I'll also want to add "%F" to record the type of file system involved along with any available "volume label" once I discover how to learn that detail.
Ultimately, I'll want to be able to identify duplicates not only by name and size but also by MD5SUM or similar.

Then, a search by file name would allow me to recover which drive some data is currently on.

~~~ 0;-Dan

Dark_Helmet 02-06-2012 03:01 PM

I don't use the program myself, but...

I noticed a couple of screenshots on this page. There is a thumbnail labeled "Automatic detection of device" that shows the content of the "Management" tab.

Based on what's presented in that screenshot, you would specify a top-level folder in the "Select disk" prompt and click the "Scan disk" button at the bottom of the window.

I say that because I also took a look at the source code. There are various places that indicate the disk is "scanned" for media files to add once that button is pressed.

SaintDanBert 02-06-2012 10:12 PM

Are you saying that GWhere only cares about file systems mounted /media/*
or will it worry about other file systems if I configure it correctly?

Hmmmm... now where are the configuration pages within the application?
... or do I need to edit some dot-rc or dot-conf file somewhere?

~~~ 8d;-/ Dan

Dark_Helmet 02-06-2012 10:30 PM

I really can't say. Because I don't use it, I don't want to indicate it does something that it doesn't do.

That said, I may try to compile and run it when I have a moment and see what I can find out.

Dark_Helmet 02-07-2012 02:30 AM


Originally Posted by SaintDanBert
Are you saying that GWhere only cares about file systems mounted /media/*
or will it worry about other file systems if I configure it correctly?

I installed it... though, that turned out to be a minor ordeal. I tried to install it from source, but ran into multiple problems. Enough that I decided to install it through the Debian repository.

Anyway, once loaded, the management tab behaved more or less as I anticipated. The "Select disk" box is not free-form like I thought. It seems to be populated with mountpoints (i.e. filesystem boundaries)--which makes sense.

If all your external disks are mounted somewhere under /media, then I would anticipate that there will be a separate entry in the "Select disk" drop-down for each device that is mounted. Though, I cannot verify that because I installed it in a virtual machine, and the virtual machine is not configured to handle host USB devices at the moment.

There is no documentation to speak of--that I've found. So, you may be in for a bit of experimentation to figure everything out.

SaintDanBert 02-07-2012 11:54 AM

I looked at the management tab more than once and never realized what you said about the select tab. Now it makes sense.

Roger the lack of documentation. It seems that they give awards these days for the fewest bytes of non-code in a package. I worked in software product development for 30+ years and we always had reasonable documents to accompany our executables. How else did one create a reasonable test plan ... but I digress.

I managed to load a catalog of $HOME and the mounted SD card. From there I could paw around and play a bit. Clunky, but does what I want.

If you Export a catalog, you get several different spreadsheets appended.
Since a spreadsheet page is simply an alternate representation of a database table,
each of these sheets is just the tables that GWhere uses for its records.
  • One for the overall catalog.
  • One for all defined Categories.
  • One for all drives that were processed.
  • One that contains all of the drive contents.

The program creates a SOMETHING.CTG file as the catalog database. Mint-12 wants to open this file using the ArchiveManager by default.

~~~ 0;-Dan

SaintDanBert 02-07-2012 12:11 PM

For those who might be interested when they stumble across this thread, here is what I've learned about the GWhere data tables:

The Catalog itself:

The various categories of contents:

The collection of disk devices used:

The file contents of all drives scanned:

NOTE -- Some of the heading words are not spelled "correctly" I'm reporting
exactly what I got from gwhere with the addition of some formatting for readability.

There is an option to Import a CSV catalog into Gwhere along with exporting a catalog from Gwhere. The exported catalog is a concatenation of everything gwhere knows. I've no idea how to proceed with an import of something like that unless gwhere knows how to read its own exports (that would make sense).

All times are GMT -5. The time now is 07:22 AM.