LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Trouble setting up Tor (https://www.linuxquestions.org/questions/linux-software-2/trouble-setting-up-tor-613071/)

MyHeartPumpsFreon 01-12-2008 07:53 AM

Trouble setting up Tor
 
Hey,

I'm trying to set Tor for the first time and I'm having a bit of trouble. I'm following the guide here: http://www.torproject.org/docs/tor-doc-unix.html.en

Everything seems to be going fine all the way up to the point where I test to see if Tor is doing what it's supposed to. I enable Tor, go to the checker website but it says: The proxy server is refusing connections. Firefox is configured to use a proxy server that is refusing connections. Check the proxy settings to make sure they are correct. Contact your network admin to make the proxy server is working.

I'm not entirely sure, but I think this might be a problem with Privoxy. I've installed it, but I'm not exactly sure how to get it up and running. I'm using a sample configuration file as shown here: https://wiki.torproject.org/noreply/.../PrivoxyConfig
I also tried configuring it by hand as instructed by the how-to, but neither work.

This how-to said that if there is a firewall, it's possible this may block Tor. I have zero experience with SELinux and SELinux Management. So, I have no idea how to add exceptions or anything like that. I know this probably just a simple Google, but I'm avoiding it out of laziness. So, I just completely disabled it. This did nothing.

I think my problem lies with Privoxy. In the sense that it isn't up and running. Can someone please tell me where I am going wrong here? Maybe something is left out? All input is appreciated.

Thanks,

Brandon

MyHeartPumpsFreon 01-12-2008 03:27 PM

Update:

With a bit of googling, it says that I had to change the connection settings in Firefox. This is what it looks like now: http://www.flickr.com/photos/22831488@N08/2188505182/
However, I can only browse the internet when the setting is on "Direct connection to the internet."

I didn't realize that Tor needs to be running from the command line (I think?). So, I started that (Tor says that it created a circuit successfully and the client appears to be functioning) , changed the connection settings in Firefox, yet it still doesn't work. I went back to the Privoxy config file that I change by hand. I followed the how-to in my first post to a T, character for character. I would post it, but it goes way past the alloted character limit, by about 10,000.


I really feel like this is something stupid that I'm missing. So, any help is appreciated.

Thanks.

Brandon

win32sux 01-12-2008 04:44 PM

Please post the output of these commands (use code tags for readability):
Code:

cat /etc/privoxy/config | grep -v ^# | grep -v ^$
Code:

cat /etc/tor/torrc | grep -v ^# | grep -v ^$
Code:

cat /etc/tor/tor-tsocks.conf | grep -v ^# | grep -v ^$
Code:

netstat -an --inet | grep LISTEN
PS: I clicked the link you posted but got a message that said "Flickr is having a massage", so if you could just post your proxy configuration directly it would be great. You can do that by running a command like:
Code:

cat ~/.mozilla/firefox/d8ej4s6d.default/prefs.js | grep "network.proxy"
The part in bold will have a different value on your system (it's randomly-generated AFAICT), so you'll need to adjust that part to match yours.

MyHeartPumpsFreon 01-12-2008 06:32 PM

Thanks for your response. Here are the output of the commands you requested.

Code:

[Elwood@localhost ~]$ cat /etc/privoxy/config | grep -v ^# | grep -v ^$
forward-socks4a / 127.0.0.1:9050 .
trust-info-url  http://www.example.com/why_we_block.html
trust-info-url  http://www.example.com/what_we_allow.html
confdir /etc/privoxy
logdir /var/log/privoxy
actionsfile standard  # Internal purpose, recommended
actionsfile default  # Main actions file
actionsfile user      # User customizations
filterfile default.filter
debug  4096 # Startup banner and warnings
debug  8192 # Errors - *we highly recommended enabling this*
listen-address  127.0.0.1:8118
toggle  1
enable-remote-toggle  1
enable-remote-http-toggle  1
enable-edit-actions 1
buffer-limit 4096
forwarded-connect-retries  0

Code:

[Elwood@localhost ~]$ sudo cat /etc/tor/torrc | grep -v ^# | grep -v ^$
Password:
SocksPort 9050 # what port to open for local application connections
SocksListenAddress 127.0.0.1 # accept connections only from localhost
DataDirectory /var/lib/tor/.tor
Group toranon
User  toranon

The above one was weird, I had to be sudo/root. Couldn't do it as a user.

Code:

cat /etc/tor/tor-tsocks.conf | grep -v ^# | grep -v ^$
There was such no file or directory for this one.

Code:

[Elwood@localhost ~]$ netstat -an --inet | grep LISTEN
tcp        0      0 0.0.0.0:111                0.0.0.0:*                  LISTEN     
tcp        0      0 127.0.0.1:631              0.0.0.0:*                  LISTEN     
tcp        0      0 127.0.0.1:25                0.0.0.0:*                  LISTEN     
tcp        0      0 127.0.0.1:9050              0.0.0.0:*                  LISTEN     
tcp        0      0 0.0.0.0:39742              0.0.0.0:*                  LISTEN

Seems like a whole lot of nothing going on here. Maybe this and the above command are showing who the culprit is?

Code:

[Elwood@localhost ~]$ cat ~/.mozilla/firefox/wu2pvbrm.default/prefs.js | grep "network.proxy"
user_pref("network.proxy.http", "localhost");
user_pref("network.proxy.http_port", 8118);
user_pref("network.proxy.socks", "localhost");
user_pref("network.proxy.socks_port", 9050);
user_pref("network.proxy.socks_remote_dns", true);
user_pref("network.proxy.ssl", "localhost");
user_pref("network.proxy.ssl_port", 8118);

Thanks again for the prompt response.

Regards,

Brandon

win32sux 01-12-2008 06:58 PM

Your Privoxy config looks to me like it's ready to go. So does your Tor and Firefox. Not sure why you don't have a tor-tsocks.conf but I would assume defaults are used if it is absent. FWIW, mine looks like this (didn't need to edit it after install):
Code:

server = 127.0.0.1
server_port = 9050
local = 127.0.0.0/255.128.0.0
local = 127.128.0.0/255.192.0.0

That said, your netstat shows Privoxy isn't listening. So it would seem you just need to start it in order to proceed. What distro are you using? On Ubuntu/Debian you start Privoxy with a:
Code:

/etc/init.d/privoxy start
You should then see it listening on 127.0.0.1:8118.

MyHeartPumpsFreon 01-12-2008 07:06 PM

If I weren't heterosexual, I would kiss you. I didn't think it was pertinent, because I thought it was something that started automatically (Privoxy), but that was the command. 'sudo /etc/init.d/privoxy start'

Thanks a million.

Solved.

Brandon

P.S. I'm using Fedora 8.

P.P.S Do Tor and Privoxy need to be started from the command line before I can successfully browse in anonymity?

win32sux 01-12-2008 07:08 PM

LOL! Cool, I'm happy to help. :)

win32sux 01-12-2008 07:18 PM

Quote:

Originally Posted by MyHeartPumpsFreon (Post 3020549)
P.P.S Do Tor and Privoxy need to be started from the command line before I can successfully browse in anonymity?

That would depend on what your distro did when the packages were installed. On Ubuntu these babies get auto-started right after the install is finished IIRC, and then get auto-started during system startup every time. From what you've described, Fedora does things differently (as it didn't start Privoxy after installing it). But my guess is that since it made an entry in /etc/init.d then it should have set up the startup links too. So maybe just do a reboot and then check if Tor and Privoxy are up by doing a netstat. Here's what mine looks like:
Code:

win32sux@candystore:~$ sudo netstat -pantu | grep LISTEN
tcp        0      0 127.0.0.1:3306          0.0.0.0:*              LISTEN    5125/mysqld       
tcp        0      0 127.0.0.1:80            0.0.0.0:*              LISTEN    5972/apache2             
tcp        0      0 127.0.0.1:8118          0.0.0.0:*              LISTEN    5600/privoxy       
tcp        0      0 127.0.0.1:631          0.0.0.0:*              LISTEN    5048/cupsd         
tcp        0      0 127.0.0.1:25            0.0.0.0:*              LISTEN    5546/exim4         
tcp        0      0 127.0.0.1:9050          0.0.0.0:*              LISTEN    5612/tor           
win32sux@candystore:~$

Whether they "need" to be auto-started during system startup is subjective. If you prefer to start them yourself you could do it that way. Personally I rather not think about it so I prefer the more hassle-free approach of just letting them get auto-started so they are ready whenever I need them.

MyHeartPumpsFreon 01-12-2008 10:21 PM

Wow, I put the commands 'tor' and '/etc/init.d/rc.local' into rc.local and completely ruined a couple of hours of my night.

It was going through the scroll screen, showing that everything was ok, but when it got to anacron it showed that Tor started and then it went to a blank blue screen. Nothing would happen. I tried booting with Knoppix CD to edit the rc.local file, but it wouldn't allow me to edit it. Something about a link not being the same or something along those lines. I could view the file, see what I had entered, but when I would attempt to edit it, it would show a file that looked nothing like what it really is (yes, I did do it as root still the same result). For whatever reason my Fedora 8 DVD did not want to boot, but eventually I got it to do a reinstall. Any idea how to avoid all of that next (which I'm sure there will be a next time) time that happens?

500MBs of updates here I come!

After restarting my computer (before the screwup), Privoxy nor Tor started up. I had to start them myself, hence the reason for me putting them into rc.local.

I guess this problem is solved though.

Thanks,

Brandon


All times are GMT -5. The time now is 08:03 PM.