LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Trouble installing Kodi using Slack Build (https://www.linuxquestions.org/questions/linux-software-2/trouble-installing-kodi-using-slack-build-4175591756/)

Lainon 10-19-2016 01:58 PM

Trouble installing Kodi using Slack Build
 
Hello wired people

I'm currently having an issue running the SlackBuild for kodi on my new Slackware 14.2 install. The build is this one:

https://slackbuilds.org/repository/1...ltimedia/kodi/

I've installed the required packages the Slackbuild page details. I have no oss.conf file in /etc/. When I try to run the build script I get the following errors:

Code:

CMakeFiles/projectM.dir/build.make:230: recipe for target 'CMakeFiles/projectM.dir/BeatDetect.cpp.o' failed
make[4]: *** [CMakeFiles/projectM.dir/BeatDetect.cpp.o] Error 1
make[4]: Leaving directory '/tmp/SBo/xbmc-15.2-Isengard/xbmc/visualizations/XBMCProjectM/libprojectM'
CMakeFiles/Makefile2:67: recipe for target 'CMakeFiles/projectM.dir/all' failed
make[3]: *** [CMakeFiles/projectM.dir/all] Error 2
make[3]: Leaving directory '/tmp/SBo/xbmc-15.2-Isengard/xbmc/visualizations/XBMCProjectM/libprojectM'
Makefile:127: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/tmp/SBo/xbmc-15.2-Isengard/xbmc/visualizations/XBMCProjectM/libprojectM'
Makefile:26: recipe for target 'libprojectM/libprojectM.so' failed
make[1]: *** [libprojectM/libprojectM.so] Error 2
make[1]: Leaving directory '/tmp/SBo/xbmc-15.2-Isengard/xbmc/visualizations/XBMCProjectM'
Makefile:372: recipe for target 'xbmc/visualizations/XBMCProjectM' failed
make: *** [xbmc/visualizations/XBMCProjectM] Error 2

I'm new to Slackware and Linux in general so please be patient with me as no doubt I'll be doing something stupid. Any extra information I can provide you with please just ask.

Thank you for your time.

EDIT:

Hang fire. I knew I must've been doing something stupid. It appears that I'm trying to install the 14.1 build instead of the 14.2 build. I'll try the latest one and report back.

EDIT 2:

Yes it was that. I'd been struggling for hours and as soon as I asked for help I found the solution staring me in the face.

astrogeek 10-20-2016 10:56 PM

Quote:

Originally Posted by Lainon (Post 5620147)
Yes it was that. I'd been struggling for hours and as soon as I asked for help I found the solution staring me in the face.

It happens, but you won't forget that one again I'll wager!

Welcome to GNU/Linux and Slackware!

Thanks for the final report and marking the thread solved!


All times are GMT -5. The time now is 07:15 PM.