LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   trouble creating symlink for java/mozilla (https://www.linuxquestions.org/questions/linux-software-2/trouble-creating-symlink-for-java-mozilla-297390/)

MightyKC 03-03-2005 10:17 PM

trouble creating symlink for java/mozilla
 
I have FC2. I followed the guide at Linux Answers for installing java1.5.0_01. When those directions stopped matching what was happening I followed the directions at Java.com. I have no doubts that I successfully turned the .bin file into an RPM, created /usr/java, and installed jre1.5.0_01 into it. However, I entered the following:
Example:

* If Mozilla is installed in this directory:
/usr/lib/mozilla-1.4/
* and if the JRE is installed at this directory:
/usr/java/jre1.5.0
* Then type at the terminal to go to the browser plug-in directory:
cd /usr/lib/mozilla-1.4/plugins
* Enter the following command to create a symbolic link to the Java Plug-in for the Mozilla browser.
ln -s /usr/java/jre1.5.0/plugin/i386/ns7
/libjavaplugin_oji.so .

# Start Mozilla browser or restart it if it is already running. Note that if you have other Mozilla components (ie: Messenger, Composer, etc) running, you will need to restart them as well.
# Go to Edit > Preferences. Under Advanced category > Select Enable Java

I followed these instructions precisely. When I still couldn't see java things I went back to the Linux Answers thing and added in these:

Then you will have to remove all the default java associations by doing the following:

code:

# cd /usr/bin
# rm java javac jar



If you get an error in removing any of the files java, javac, OR jar, it's okay, it's just to make sure you remove them. You will have to confirm to remove these files by typing a y at the prompt.

Next, you will have to create a link between the newly installed VM and the defaults for FC2 java vm by using the following command:

code:

# cd /usr/bin
# ln -s /usr/java/j2re1.4.1_01/bin/java java



STill no plugin. I closed each Mozilla window every time I trouble shooted it.
I searched this forum for other examples. I know that they are for different versions of mozilla (I have 1.6) or java, but I tried the following links (substituting version numbers):


1. Go to the plugins sub-directory under the Mozilla installation directory
cd <Mozilla installation directory>/plugins
2. In the current directory, create a symbolic link to the JRE ns610-gcc32/libjavaplugin_oji.so file Type:
ln -s <JRE installation directory>/plugin/i386/ns610-gcc32/libjavaplugin_oji.so


ln -s /path/to/java/j2re1.4.2_<version>/plugin/i386/ns610-gcc32/libjavaplugin_oji.so /path/to/mozilla-1.7.5/plugins/libjavaplugin_oji.so


I also tried ns7-gcc32 I believe, altough somewhere I remember seeing that ns7 should have worked in the first place. Anyone have any thoughts on where I went wrong?

wolfe2554 03-04-2005 12:40 AM

I did it with mozilla 1.7 and java 1.4.02_07
I installed both and then I went to

cd ~/.mozilla/plugins/
ln -s /usr/local/java/j2re-1.4.02_07/plugin/i386/ns610-gcc32/
libjavaplugin_oji.so .

then restarted and worked like a dream. one thing though test that the user in question has access to the path by loging in as the person and attempting to edit the libjavaplugin ok. If it says permission denied do a chmod a+rx on the file as root. then each dir recursivly.

good luck mozilla is mean with java sometimes.
wolfe2554


All times are GMT -5. The time now is 05:13 PM.