LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   trouble compiling w/c++ (https://www.linuxquestions.org/questions/linux-software-2/trouble-compiling-w-c-299694/)

eroica 03-09-2005 02:02 PM

trouble compiling w/c++
 
hello,
i'm trying to compile a program off kde.org(k-bandwidth) and when i run the ./configure script i get the following:
checking if C++ programs can be compiled... no
configure: error: Your Installation isn't able to compile simple C++ programs.
Check config.log for details - if you're using a Linux distribution you might miss
a package named similiar to libstd++-dev.

I then installed the packages libstdc++5-static-devel & libstdc++5-devel but I still get same error when trying to compile k-bandwidth. i'm reletively new to linux and wanted to know if someone had any suggestions on if i have right packages installed or if i need to update a config file to point to a certain directory. i'm running mandrake 9.1. I do see a directory /usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.2.2/include but is this is in some nonstandard place?

thanx alan

scuzzman 03-09-2005 02:09 PM

You need to install the development packages with Mandrake.
You can do this through Add Software.

eroica 03-09-2005 02:41 PM

ok added gcc -c++ package but now get this when i run ./configure:
checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!
any ideas what package or where this should be?

alan

foo_bar_foo 03-09-2005 03:01 PM

basically all the packages have their coresponding developement packages that you need
dividing the packages in two like this binary and devel is one of the great linux blunders of all time
but you got to deal with it

eroica 03-09-2005 03:17 PM

yeah but do i need to add some X libraries now or are they not in a standard place???
alan


All times are GMT -5. The time now is 11:34 PM.