-   Linux - Software (
-   -   Tries to boot in the Gnome but just flashes... (

XxAndyxX 05-04-2003 10:05 PM

Tries to boot in the Gnome but just flashes...
I just finished installing Linux on my server and installed Samba and a bunch of other programs and when I went to reboot the server and it tried to boot back into gnome... It just goes to the
'localhost login:' text screen then it (normally boots into the gnome login screen) but now it just flashes that screen then goes black... flashes then goes black... etc... How do I get it to boot!!! HELP!


chem1 05-04-2003 10:24 PM

try booting into init3 level instead of init 5 level. init5 is the graphical level and for some reason it seems that your XF86Config file is goofed up.
Here is the way to do that:
1) When the screen is flashing try hitting Ctrl+Alt+F1
2) Otherwise try going into intercative boot when Linux is starting. With RedHat it can be done by pressing 'I' at boot
3) Once you are in the command prompt type cd /etc/X11.
This is the directory where your XF86Config file resides.
4) Open that file using either vi editor or some other editor that you have
5) Find the section which says "Screen"
6) withing this section delete all modes greater that 640x480
7) Check for the section named Device. Does it have your actual hardwrae listed for display

Save the file and reboot...should work OK

Hope that helps...

XxAndyxX 05-04-2003 11:28 PM

I think that might work! But there's a probley... I've tried both pressing 'i' a million times... and it doesn't work... and when I press ctrl+alt+F1 it doesn't work. It usually goes into text mode when I press ctrl+alt+F2 but that doesn't work either. I don't have a bootdisk because I don't have a floppy on this computer just a CD-ROM which I use to boot up with... Is there any other ways I can get into text mode?

BigNate 05-05-2003 06:17 AM

which distro? I'll assume RH since you are saying "normally boots into Gnome" as that is the default DE for redhat. The first cd for the RH install can act as a rescue disk. Boot up with that and choose the option for rescue.

XxAndyxX 05-05-2003 07:37 AM

I ran the rescue disk and booted into command line... The I got into /etc/X11 and typed 'vi XF86Config' I looked on the internet for commands for vi put none of them seems to work... I used the arrow keys to go down to Section Monitor...

Identifier "Monitor0"
VenderName "Monitor Vender"
ModelName "Monitor Model"
HorizSync 31.5-48.5
VertRefresh 50-70
Option "dpms"


Then under Section "Screen"
Identifier "Screen0"
Device "Trident CyberBlade(generic)"
DefaultDepth 16

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"


Okay... I moved my cursor into the "Modes "1024x768" "800x600" "640x480" " line... Then I deleted everything so that the only thing that was left was (Modes "640x480")

Then I saved it... but it still does that same thing that I've stated in the original post...?????

XxAndyxX 05-05-2003 11:17 AM

I've changed the depth's from 16 to 4 and it still doesn't make a difference. It does the same thing... Please help...


chem1 05-05-2003 04:14 PM

OK...have you checked at the Trident site for the proper driver of your card. Are there any issue listed.
This seems to be a strange problem because normally the display would come back after your resolution is set to minimum and your Horiz/Vert Sync seem to be OK

BigNate 05-05-2003 05:01 PM

case matters. You need to run:


You wont need to use vim as it is an interactive dialog that allows for you to configure X

All times are GMT -5. The time now is 03:43 PM.