-   Linux - Software (
-   -   Totem & VLC starts for only 2 seconds... (

crash_override_me 07-02-2008 02:21 AM

Totem & VLC starts for only 2 seconds...
hi all,

this is a seemingly new problem i started facing in debian etch a few days back.
whenever i try to play a movie in either of the 2 media players i have: totem and vlc, the app. starts, works for just a second or 2 then closes.
moreover, sometimes this also leads to X-server restarting, as i am shown the login window again!

is this is a known bug or something...??
i have gnome 2.14.3

farslayer 07-02-2008 07:52 AM

Have you tried launching them from a shell so you can view the error that gets thrown when it shuts down ? usually a good place to start for this sort of problem..

crash_override_me 07-02-2008 03:18 PM

i tried starting totem and vlc from the shell, and both are working fine from there!
so, is this a gnome bug..?

farslayer 07-02-2008 08:53 PM

If you are running etch then I don't think so as it works perfectly well on my etch system..

Are you by chance mixing repositories, pulling in things from testing, unstable, volatile, backports, other ?

Did you recently install something on your system right before this problem first occurred ?

have you tried purging the packages from your system then re-installing them ?

crash_override_me 07-03-2008 02:30 AM

these are repos i am using:


# deb etch/updates main contrib
# Line commented out by installer because it failed to verify:
deb etch main
# deb-src etch/updates main contrib
deb etch-backports main contrib non-free

& yeah, i recently installed apache, php and mysql.

farslayer 07-03-2008 10:58 AM

output of: apt-cache policy vlc

vlc 0.8.6-svn20061012.debian-5.1+etch2 [security]

it should be from the security repo that you have commented out in your first line.

crash_override_me 07-04-2008 11:44 AM

$apt-cache vlc gives:

  Installed: 0.8.6-svn20061012.debian-5etch1
  Candidate: 0.8.6-svn20061012.debian-5etch1
  Version table:
 *** 0.8.6-svn20061012.debian-5etch1 0
        500 etch/main Packages
        100 /var/lib/dpkg/status

farslayer 07-06-2008 01:12 AM

You may want to try uncommenting the security repository and updating your system.

crash_override_me 07-06-2008 01:19 PM

i uncommented that line and ran:
$apt-get update

the following error cropped up:

GPG error: etch-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EA8E8B2116BA136C

farslayer 07-06-2008 10:02 PM

If you have backports in your sources.. did you follow the instructions ?

crash_override_me 07-07-2008 02:20 PM

thanx, the error is gone after importing the gpg key

blm777 07-11-2009 12:57 PM

I am having the same problem with both Totem and VLC shutting down, moments after I try to open an .avi file.
Everything was fine until my friend updated me from an older mandriva to Ubuntu...we tried going back to Mandriva, but the problem remains on both.
We also switched from KDE to Gnome.

I don't know much about computers, so I got lost when you started explaining the fix..
In idiot's terms, how do I do this fix? Do I just have to import a gpg key? How do I do that?


blm777 07-11-2009 02:09 PM

The info in a previous post (see below) solved the problem on VLC. Does anyone have a similar for Totem Movie Player---in idiot-proof english please!! :)


LQ Newbie

Registered: Feb 2008
Location: I am a United Kingdom penguin
Distribution: Ubuntu / PClinuxOS
Posts: 22
Thanked: 0


....I had the exact same thing happen to me whilst operating vlc with an ageing rather than ancient ati FireGL radeon a dell laptop, as it happens. What I was advised to do was to open up vlc...go to preferences, check the advanced box on the bottom right hand corner. Then select output modules and a single drop down menu will appear on the right. You may have to maximise the window to see it properly though. I frustrated myself a while over that silly little detail...I then chose X11 as my preferred output mode and hey presto, vlc works fine. There are other modes you can experiment with, but it seems as if X11 is the one to go with older hardware. I really hope this works for you...

All times are GMT -5. The time now is 01:13 PM.