Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 12-07-2007, 01:48 PM   #1
Registered: Apr 2004
Location: Louisiana
Distribution: SUSE
Posts: 154

Rep: Reputation: 30
Time won't set

I am running SLES 10 servers in a XEN environment.

No matter what I set the time to using the 'date' command on one of the servers, it will always jump back to about 6 minutes ahead of time. I disabled NTP to make sure that wasn't scrweing anything up. Originally NTP was enabled and the clock was still 5 minutes ahead of time. Below is the output of a few commands that will show the problem...

99lv01-a:/etc/sysconfig # rcntp status
Checking for network time protocol daemon (NTPD): unused <-- NTP is off
99lv01-a:/etc/sysconfig # date <-- Time is 12:47:51
Fri Dec 7 12:47:51 CST 2007
99lv01-a:/etc/sysconfig # date 12071242 <--- Setting time to 12:42:00
Fri Dec 7 12:42:00 CST 2007
99lv01-a:/etc/sysconfig # date
Fri Dec 7 12:48:00 CST 2007 <--- It goes back to 12:48
99lv01-a:/etc/sysconfig # hwclock <--- No luck w/ the hwclock command
Cannot access the Hardware Clock via any known method.
Use the --debug option to see the details of our search for an access method.
99lv01-a:/etc/sysconfig #

99lv01-b, 99lv01-c and 99lv01-d are all SLES VMs on 99lv01 but the clock works on those fine.

Any ideas?
Old 12-07-2007, 01:59 PM   #2
LQ Guru
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Hi -

You might want to look at your NTP "drift"


Just a thought .. pSM
Old 12-07-2007, 02:11 PM   #3
Registered: Apr 2004
Location: Louisiana
Distribution: SUSE
Posts: 154

Original Poster
Rep: Reputation: 30
Originally Posted by paulsm4 View Post
Hi -

You might want to look at your NTP "drift"


Just a thought .. pSM
I actually tried deleting that and starting over with no luck.

I found that if I put 'xen.independent_wallclock = 1' in /etc/sysctl.conf it won't take the time setting of the master host (99lv01). This worked even though the time on 99lv01 was set properly.

Very strange.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set and sync system time with time server?? servnov Linux - Newbie 6 12-03-2013 08:55 PM
Where does RH8 daily set system time to hardware clock time smartnorman Red Hat 1 05-24-2006 03:42 PM
Cannot set time/date to other time zone than UTC (Kubuntu) jamangold Ubuntu 1 12-23-2005 06:42 PM
Doub about `net time set` and daylight saving time Thakowbbery Linux - Software 0 10-17-2005 06:23 AM
set time mohtasham1983 Linux - Newbie 3 09-19-2005 05:23 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:08 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration