LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Time sync issue in redhat system (https://www.linuxquestions.org/questions/linux-software-2/time-sync-issue-in-redhat-system-4175608079/)

Linuxuser1987 06-17-2017 10:13 AM

Time sync issue in redhat system
 
In my redhat system, the time is showing 30 mins less than actual time.When I modify the time to actual time,after 3 mins it reverse back to previous time. Ntp is stopped.

I am getting below message from log

Jun 17 19:50:32 rzsbcx10 ntpd[4969]: ntpd exiting on signal 15
Jun 17 19:50:33 rzsbcx10 ntpd: ntpd shutdown succeeded

Pls give any solution.

scasey 06-17-2017 11:01 AM

How are you "modifying" the time to the actual time?
Why is ntp stopped?

Linuxuser1987 06-17-2017 11:50 AM

I am modifying through ntpdate by syncing with external clock.I stopped the ntpd manually so that the time can't change automatically.

rknichols 06-17-2017 12:15 PM

If this is Red Hat 7, it uses chronyd, not ntpd, for time synchronization.

michaelk 06-17-2017 12:55 PM

What version of Red Hat are you running?

It this a real or virtual machine?

Are you syncing to a NTP pool server or an internal network timeserver?

Linuxuser1987 06-17-2017 01:00 PM

Red Hat Enterprise Linux AS release 4 (Nahant Update 5)

Linuxuser1987 06-17-2017 01:01 PM

its a real machine

Linuxuser1987 06-17-2017 01:01 PM

internal network timeserver

michaelk 06-17-2017 01:06 PM

What about the other questions?

If ntpd is shutdown there should be no other process that should automatically update time unless you have some cron job that runs ntpdate.

Can you post your ntp.conf file? How does the internal time server sync time?

Linuxuser1987 06-17-2017 04:27 PM

1 Attachment(s)
I have added a cron job of ntpdate to sync with network timeserver.
#30 05 * * * /usr/sbin/ntpdate 10.201.130.89; /sbin/hwclock -w

But due to this problem I have disable this cron job and manually update the time using ntpdate but after sometime system time automatically changes but hwclock remain same.

michaelk 06-17-2017 05:02 PM

Code:

# --- OUR TIMESERVERS -----
#server 0.pool.ntp.org
#server 1.pool.ntp.org
#server 2.pool.ntp.org
server 127.127.1.0

Not sure if you commented out all the servers to troubleshoot your time problem? There must be another ntpdate cron job running somewhere. Check the logs.

Check the running processes. Are you sure ntpd is not running?

Linuxuser1987 06-17-2017 05:29 PM

Yes I have commented out those servers for troubleshoot.


I am checking with command

Service ntpd status and it is showing ntpd is stopped.

Not sure another cron job isrunning or not.How to check? except "crontab -l"

michaelk 06-18-2017 05:48 PM

Check the cron logs /var/log/cron

The system cron files are located here:

/etc/cron.d
/etc/cron.daily
/etc/cron.hourly
/etc/cron.monthly
/etc/cron.weekly
/etc/crontab

Linuxuser1987 06-19-2017 02:40 AM

[root@rzsbcx10 ~]# cd /etc/cron.d
[root@rzsbcx10 cron.d]# ls
sysstat
[root@rzsbcx10 cron.d]# more sysstat
# run system activity accounting tool every 10 minutes
*/10 * * * * root /usr/lib/sa/sa1 1 1
# generate a daily summary of process accounting at 23:53
53 23 * * * root /usr/lib/sa/sa2 -A

[root@rzsbcx10 cron.d]# more /etc/cron.daily

*** /etc/cron.daily: directory ***

[root@rzsbcx10 cron.d]# more /etc/cron.hourly

*** /etc/cron.hourly: directory ***

[root@rzsbcx10 cron.d]# more /etc/cron.monthly/

*** /etc/cron.monthly/: directory ***

[root@rzsbcx10 cron.d]# more /etc/cron.weekly/

*** /etc/cron.weekly/: directory ***

[root@rzsbcx10 cron.d]# more /etc/crontab
SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
MAILTO=root
HOME=/

# run-parts
01 * * * * root run-parts /etc/cron.hourly
02 4 * * * root run-parts /etc/cron.daily
22 4 * * 0 root run-parts /etc/cron.weekly
42 4 1 * * root run-parts /etc/cron.monthly

Linuxuser1987 06-20-2017 03:24 AM

I have stopped the cron job using command service crond stop but still time is changing.


All times are GMT -5. The time now is 03:52 PM.