LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-04-2009, 05:31 PM   #1
zlya
Member
 
Registered: Dec 2006
Distribution: Debian
Posts: 62

Rep: Reputation: 15
thunderbird won't start but ps -ef shows it running


Hello,

I have been using thunderbird successfully for several months now, with the firetray extension for the past two weeks. I have it set to start automatically when the computer turns on.

For the past week or so it has been very slow to start, often appearing several minutes after other programs have started.

Today, it did not start at all. I waited almost half an hour, nothing.

I tried starting it, both from menu and command line, and it said, "Thunderbird is running but not responding. To open a new window close thunderbird or restart your system."

I tried restarting the system, no difference.

I checked ps -ef and saw these indications that it is in fact running:

user 5142 1 0 18:23 ? 00:00:00 /bin/sh /usr/bin/thunderbird
user 5154 5142 0 18:23 ? 00:00:00 /bin/sh /usr/lib/thunderbird/run-mozilla.sh /usr/lib/thunderbird/thunderbird-bin
user 5158 5154 79 18:23 ? 00:03:34 /usr/lib/thunderbird/thunderbird-bin

So the computer thinks it's running . . . where is it? I've checked all 4 workspaces. I've tried uninstalling and re-installing. I've tried deleting the .parentlock file in the default directory under .mozilla-thunderbird.

Any advice?

Thank you!

PS: I update the system every day, I didn't specifically notice a new thunderbird update yesterday, but it's possible.
 
Old 10-04-2009, 05:56 PM   #2
stu7
Member
 
Registered: Jun 2007
Posts: 95

Rep: Reputation: 16
[QUOTE=zlya;3707645]Hello,

/snip/ I have it (thunderbird) set to start automatically when the computer turns on./snip/

** this to me sounds like a problem beginning
in your startup script ?

/snip/ I checked ps -ef and saw these indications that it is in fact running:

user 5142 1 0 18:23 ? 00:00:00 /bin/sh /usr/bin/thunderbird /snip/

** now the question becomes -not- is thunderbird
running, but, how to access the running instance

/snip/ So the computer thinks it's running

where is it? Any advice? /snip/

** it doesnt seem reasonable that the computer is simply lying to you(!)... fortunately, there is one approach you have not mentioned.

After running ps grab the process number
and do this:

fg process_number

IF the program is actually running, and you have the right permissions, that should bring it to the foreground.

Hope this works

Last edited by stu7; 10-04-2009 at 05:57 PM.
 
Old 10-05-2009, 10:02 AM   #3
zlya
Member
 
Registered: Dec 2006
Distribution: Debian
Posts: 62

Original Poster
Rep: Reputation: 15
Tried that, got:

bash: fg: 3686: no such job

Just to make sure, I tried running it on a program I knew was running, same answer. I think I'm using fg wrong. fg on its own gives:

bash: fg: current: no such job

and man fg gives:

no manual entry for fg

and sudo fg just isn't found.

So . . . help?
 
Old 10-05-2009, 10:24 AM   #4
G4george
Member
 
Registered: Nov 2005
Location: Houston, Tx
Posts: 34

Rep: Reputation: 15
It may be going to another display in stead of the one you are using.
Make sure your $DISPLAY env is correct.
 
Old 10-05-2009, 11:09 AM   #5
lutusp
Member
 
Registered: Sep 2009
Distribution: Fedora
Posts: 835

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by zlya View Post
Hello,

I have been using thunderbird successfully for several months now, with the firetray extension for the past two weeks. I have it set to start automatically when the computer turns on.

For the past week or so it has been very slow to start, often appearing several minutes after other programs have started.

Today, it did not start at all. I waited almost half an hour, nothing.

I tried starting it, both from menu and command line, and it said, "Thunderbird is running but not responding. To open a new window close thunderbird or restart your system."

I tried restarting the system, no difference.

I checked ps -ef and saw these indications that it is in fact running:

user 5142 1 0 18:23 ? 00:00:00 /bin/sh /usr/bin/thunderbird
user 5154 5142 0 18:23 ? 00:00:00 /bin/sh /usr/lib/thunderbird/run-mozilla.sh /usr/lib/thunderbird/thunderbird-bin
user 5158 5154 79 18:23 ? 00:03:34 /usr/lib/thunderbird/thunderbird-bin

So the computer thinks it's running . . . where is it? I've checked all 4 workspaces. I've tried uninstalling and re-installing. I've tried deleting the .parentlock file in the default directory under .mozilla-thunderbird.

Any advice?

Thank you!

PS: I update the system every day, I didn't specifically notice a new thunderbird update yesterday, but it's possible.
Here's how to sort this out:

1. Move Thunderbird's data files into a safe, separate repository.

2. Delete the original Thunderbird directory under your home directory.

(1 and 2 can both be accomplished by renaming the Thunderbird directory)

3. Run Thunderbird.

4. If Thunderbird appears, this means it was thrashing while trying to initialize itself and never got to the point where it could display its GUI.

If (4) is true, then you need to figure out what to do -- get more RAM, or log out and in again, then run Thunderbird by itself without competition from other applications, something like that.
 
Old 10-05-2009, 01:30 PM   #6
PTrenholme
Senior Member
 
Registered: Dec 2004
Location: Olympia, WA, USA
Distribution: Fedora, (K)Ubuntu
Posts: 4,186

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
The other option is to just sent a SIGHUP signal to the thunderbird process(es) (i.e.; kill -s SIGHUP <process #s> or just kill <process #s>) and then restart TB.
 
Old 10-05-2009, 02:22 PM   #7
zlya
Member
 
Registered: Dec 2006
Distribution: Debian
Posts: 62

Original Poster
Rep: Reputation: 15
Hi,

Thanks for all the help!

I think you were right, lutusp, and I think the culprit was the lightening extension, because when I removed storage.sdb from the profile folder under .mozilla-thunderbird directory everything worked . . . but without my calendar settings.

I've looked this up on google and it seems to be a problem that's happened to other people, but I haven't found a way to get my calendar settings out of storage.sdb apart from installing an older version of lightning, exporting them, and then reinstalling the new version (which I wouldn't necessarily know how to do because I got lightning through the thunderbird extensions menus rather than through apt).

But worst comes to worst I just reinput my calendar and remember to make backups next time.

Thanks again for all the help, it really got me thinking.
 
Old 10-05-2009, 03:10 PM   #8
stu7
Member
 
Registered: Jun 2007
Posts: 95

Rep: Reputation: 16
Quote:
Originally Posted by zlya View Post
Tried that, got:

bash: fg: 3686: no such job

Just to make sure, I tried running it on a program I knew was running, same answer. I think I'm using fg wrong. fg on its own gives:

bash: fg: current: no such job

and man fg gives:

no manual entry for fg

and sudo fg just isn't found.

So . . . help?
Sorry... I didnt explain that correctly

the fg command takes a job number, not a process id... and... you need to have stopped
the job in order to restore it with fg
my mistake.

But - we're still looking at the same basic problem... you have a process running, and want
it "in the foreground". As another replier suggests, this seems to be more a problem with managing displays. Best of luck with this.
OOPS - looks like it is working now... see...
I told you it would be easy : - )

Last edited by stu7; 10-05-2009 at 03:12 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
running top shows 2 users gibson79 Slackware 8 03-08-2007 09:19 AM
eth1 does not work.. shows UP but not RUNNING geno976 Slackware 7 07-28-2006 09:29 AM
thunderbird only shows one accout true_atlantis Linux - Software 2 01-03-2006 07:15 PM
snmp staus shows it running but on trying MRTG, it shows public@ipaddr not giving res swati220781 Linux - Networking 3 07-08-2004 05:32 PM
Can't start Mozilla while Thunderbird is running satimis Linux - Software 2 10-06-2003 08:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration