LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-07-2006, 09:14 AM   #1
fahridon
LQ Newbie
 
Registered: Jun 2005
Location: turkey
Distribution: Pardus 1.0
Posts: 14

Rep: Reputation: 0
thunderbird ldap settings?


hi,
i want use my exchange mail acount in thunderbird. i make setting for mail get and send. but i am not view general addres list. how to do ldap setting for thunderbird?
 
Old 04-07-2006, 09:32 AM   #2
brian_lad
Member
 
Registered: Feb 2006
Location: Overland Park, KS
Distribution: RedHat EL, Fedora, Ubuntu
Posts: 32

Rep: Reputation: 15
What do you have in your LDAP account settings in Thunderbird?

For instance I know that Active Directory uses port 3268 for LDAP which I believe you would have to set in Thunderbird.

Brian
 
Old 04-07-2006, 09:44 AM   #3
fahridon
LQ Newbie
 
Registered: Jun 2005
Location: turkey
Distribution: Pardus 1.0
Posts: 14

Original Poster
Rep: Reputation: 0
name: penti.com.tr
hostname: mail.penti.com.tr
base DN: dc=penti, dc=com, dc=tr
Port number: 3268
bind DN: fdonmez@penti.com.tr

this my settings. but not worked. whats the problems?
 
Old 04-07-2006, 10:07 AM   #4
brian_lad
Member
 
Registered: Feb 2006
Location: Overland Park, KS
Distribution: RedHat EL, Fedora, Ubuntu
Posts: 32

Rep: Reputation: 15
You might need to change your bind DN entry to use the netbios name....
(domain name\username)

Brian
 
Old 04-07-2006, 11:10 AM   #5
brian_lad
Member
 
Registered: Feb 2006
Location: Overland Park, KS
Distribution: RedHat EL, Fedora, Ubuntu
Posts: 32

Rep: Reputation: 15
FYI I found this information in an Exchange Server Forum:

1. The default LDAP port for Active Directory is 3268 (not 389) so make sure you've got this port open thru the firewall, and make sure to configure it in your LDAP account settings in Mozilla/Thunderbird.

2. For Base DN, you MUST enter something like dc=yourdomain,dc=com (whereas Outlook Express lets you get away with putting NULL).

3. For Bind DN, you must enter a domain user which has permission to search the directory. You should enter it qualified by the NetBIOS domain name, for example: mydomain\username

4. For some reason, Thunderbird doesn't always seem to recognize that it needs to log on before querying. The easiest, most reliable way I have found to force it is to go to the Offline tab in the Directory Server Properties and click the Download button. This function seems to "see" that Active Directory wants a logon, so Thunderbird will display the logon dialog to let you enter your domain credentials. For the username, specify exactly the same thing you put into Bind DN.

5. Results are returned asynchronously to the Thunderbird Address Book, so you might see "No matches found" immediately after clicking the Search button. Wait a few seconds, and your results should show up.

6. Mozilla and Thunderbird default to a Search Filter of (objectclass=*) which will return lots of useless (non-email address) entries from Active Directory. You can override this with something like (objectclass=person) on the Advanced tab of Directory Service Properties. Depending on what kinds of addresses are in your Active Directory, you may need to refine this filter more (for example, if you've got mail-enabled Public Folders which you want to display).

7. The Address Book UI in Thunderbird is just clumsy. You CANNOT search an LDAP directory by simply selecting it on the left hand side and then entering your search in the "Name or Email contains" textbox. You MUST click the Advanced button to define an LDAP search. After you find your desired address(es) in LDAP, you "should" be able to copy it to your local addresses but the stupid UI only lets you look at the Properties or add it to the recipient list for a new message (by clicking the Write button).
 
Old 04-08-2006, 01:56 AM   #6
fahridon
LQ Newbie
 
Registered: Jun 2005
Location: turkey
Distribution: Pardus 1.0
Posts: 14

Original Poster
Rep: Reputation: 0
i try the this settings...
name: penti.com.tr
hostname: b2b.penti.com.tr (exchange server)
base DN: dc=penti, dc=com, dc=tr
Port number: 3268
bind DN: penti.com.tr/fdonmez

but not worked...

i click offline->download now button
and
the dialog box "status=replication entiry...."
and "replicating directory enty: 10"

but addres list dont come.

on the exchange server or dc need the any configiration for ldap?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Thunderbird + NDS + LDAP = No Dice player_2 Linux - Software 5 02-22-2006 10:59 AM
Thunderbird settings from Windows XP to SuSE 10.0 RedShirt Linux - Software 9 11-06-2005 04:04 PM
How to port over Firefox and Thunderbird Settings Mic Q SUSE / openSUSE 0 12-21-2004 06:47 AM
Thunderbird Folder Settings.. ImpactDNI Linux - Software 3 08-31-2004 09:54 AM
ldap-abook unable to get street name in ldap-entry Jingle Linux - Software 1 06-06-2004 07:13 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration