-   Linux - Software (
-   -   thunderbird is already running but not responding (

wearetheborg 01-09-2006 08:27 PM

thunderbird is already running but not responding
My Redhat system froze and I did a hard reboot. After that both firefox and thunderbird are giving a message like:

"thunderbird is already running but not responding..."

I removed the lock in the profiles directory but no go.
For firefox I finally erased the profile firectory and restarted, now its fine. But thunderbird has some stored mail so I do not want to do that. Also, I donot have root access. Any help?

PTrenholme 01-09-2006 10:32 PM

I'm not sure where your "lock" is to be found, but you could try creating a new profile and moving the mali files and settings from your old profile to the new one.

I use a "shared" profile, so the same mailbox is available from all systems on the network:

$ cat .thunderbird/profiles.ini

Name=Default User

and used that "trick" to move mail from XP systems to the "shared" mailbox, so it should work for you.

Oh, if you go to a command line, thunderbird --help will show you the options you have available for starting TB, and, of course, without the --help, might display some helpful error message.

wearetheborg 01-10-2006 05:49 AM

How do I move mail and settings to a new profile ?

PTrenholme 01-10-2006 09:08 AM

Just copy the files in the directory (and all subdirectories) referenced by the old path= line in the ~/.thunderbird/profiles.ini file to the new profile location.

Check out the pax command for copying directory trees. (Look at man pax.) You might consider making more than one copy for backup in case something goes wrong. :)

Edit: Oh, did you get any error messages when you tried to start TB from a command line? (I.e., what hapened when you typed $thunderbird &?)

wearetheborg 01-10-2006 03:28 PM

Oh, I was starting TB from the command line(first there were some warning/error messages (that I also get with firefox - I installed both in my home directory - dont have root perm) then a window popped up saying "TB already in use bla bla"
Is pax different from cp -R ?

I tried renaming the profile directory to something else (with appropriate adjustment on "path=" in profile.ini - it didnt work. I'll try creating a new directory and moving everything as u suggested.

SYS49152 07-24-2008 11:11 PM

Maybe check the path to your profile
This old thread came up for my problem, so I just want to add for anyone else's benefit..

For me this error came up ("Thunderbird already running...") after I relabelled my drives in fstab. Thunderbird, in /home/[me]/.mozilla-thunderbird/profiles.ini, still had the old path to my email folder. Just updating that fixed it. I expect this would also happen if I were to move that folder somewhere.

cocha 12-08-2008 04:15 PM

.parentlock file in the profile
I've had the same problem and the reason was the .parentlock in my profile. Simply deleting the lock file solved it. The path in profiles.ini was correct.

Greystoker 03-23-2009 03:54 PM

The solution to me
I also had the problem with "thunderbird is already running..."

In directory home/your name/.mozilla-thunderbird there is a file named "profiles.ini"

It was looking like this







In the Path I deleted the Profiles/ Now it was Path=nnlzo4f7.default.

And now the thunderbird worked properly!

(nnlz04f7.default is the name of the file that contains all thunderbird data such as mails, settings... It is in the same folder as profiles.ini)

Thulemanden 11-17-2009 01:21 PM

I have had it with TB
I don't understand why people are satified running an unstable software like Thunderbird

I have seen this so often with TB.

Think I need to rely on webmail.

paladin_iii 09-06-2011 01:52 PM

Also, may need to mount the shared filesystem.
I followed the suggestions, posted here and elsewhere, to set up a shared profile for TBird. Finally got it to work, ONE TIME! Sent an email in Linux and read it in Win7. Tested the reverse; sent email in Win7, re booted to Linux, invoked TBird and got the failure message in this post. Eventually I started poking around the file system in a terminal window and found that Linux could not see my shared profile. (In Mint Linux), went to "Administration", then to "Disk Utility", then clicked on my hard disk, clicked on my NTFS shared data area (which I had partitioned expressly for sharing data such as TBird between Linux and Win7), clicked "Mount Volumn" and, voila, TBird came up with everything in it.
Now I've just got to figure out how to have the system mount that partion at boot time.

All times are GMT -5. The time now is 02:38 AM.