LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-29-2007, 01:59 AM   #1
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Rep: Reputation: 128Reputation: 128
Thunderbird does not play sound file properly in Slackware-12.0


Since Slackware-9.1 I've used this sound file from Windows for email notification:
Code:
root@wired_silas:~# ls -lh /WinXP/WINDOWS/Media/ringin.wav
-r-------- 1 root root 9.8K 2002-09-01 20:00 /WinXP/WINDOWS/Media/ringin.wav
Slackware-12.0 has Thunderbird-2.0.0.4 as the default. The first computer where I installed Slackware-12.0 would not play that sound file, and I thought it was a problem with the sound system. However, I've since installed Slack-12.0 to three other computers, and it doesn't work on any of them, either.

The file will play from CLI with mplayer, aplay, and play just fine:
Code:
root@wired_silas:~# mplayer /WinXP/WINDOWS/Media/ringin.wav
MPlayer 1.0rc2-4.1.2 (C) 2000-2007 MPlayer Team
CPU: AMD Athlon(tm) 64 Processor 3200+ (Family: 15, Model: 4, Stepping: 10)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.

Playing /WinXP/WINDOWS/Media/ringin.wav.
Audio file file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 11025 Hz, 1 ch, u8, 88.2 kbit/100.00% (ratio: 11025->11025)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [oss] 11025Hz 1ch u8 (1 bytes per sample)
Video: no video
Starting playback...
A:   0.2 (00.1) of 0.9 (00.9)  0.0%

Exiting... (End of file)
root@wired_silas:~# aplay /WinXP/WINDOWS/Media/ringin.wav
Playing WAVE '/WinXP/WINDOWS/Media/ringin.wav' : Unsigned 8 bit, Rate 11025 Hz, Mono
root@wired_silas:~# play /WinXP/WINDOWS/Media/ringin.wav

Input Filename : /WinXP/WINDOWS/Media/ringin.wav
Sample Size    : 8-bits
Sample Encoding: unsigned
Channels       : 1
Sample Rate    : 11025

Time: 00:00.91 [00:00.00] of 00:00.91 ( 100.0%) Output Buffer:   9.98K

Done.
root@wired_silas:~#
Since the sound system seemed okay, I tried upgrading to Thunderbird-2.0.0.6 in Slackware -current. It wouldn't play that sound file, either. Since it last worked in Thunderbird-1.5.0.7 in Slackware-11.0, I tried that package. It won't play with that, either. So, I can deduce that the problem is not Thunderbird, but rather, Slackware-12.0.

I tried some other sound files, and found they would play. This one:
Code:
mingdao@wired_silas:/usr/share/sounds$ ls -lh KDE_Startup.wav
-rw-r--r-- 1 root root 357K 2005-09-10 16:25 KDE_Startup.wav
will play completely. However, this one:
Code:
mingdao@wired_silas:/usr/share/sounds$ ls -lh k3b_success1.wav
-rw-r--r-- 1 root root 46K 2007-06-24 02:35 k3b_success1.wav
plays partially, but not completely.

There are other files, such as this one:
Code:
mingdao@wired_silas:/usr/share/sounds$ ls -lh KDE_Startup_new.wav
-rw-r--r-- 1 root root 949K 2005-09-10 16:14 KDE_Startup_new.wav
which seem to play completely in Thunderbird.

I was also told to disable arts in KDE's control center, so I did:
Code:
mingdao@wired_silas:/usr/share/sounds$ ps aux | grep arts
mingdao   3484  0.0  0.0   2000   636 pts/6    R+   13:45   0:00 grep arts
so that ALSA would be used alone, but this changed nothing.

Google searches came up with nobody having this problem. It can't be this computer, since there are 3 others, all with different hardware (sound chipsets included) with the same problem. And trying different versions of Thunderbird on them makes no difference. The common denominator is Slackware-12.0. We didn't have this problem prior to version 12.0.
 
Old 10-29-2007, 02:10 AM   #2
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Have you gone into the about:config for T-Bird and messed with any of the sound settings?
 
Old 10-29-2007, 02:14 AM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Original Poster
Rep: Reputation: 128Reputation: 128
Assuming you mean about:config such as Firefox's, where in Thunderbird would that be located?
 
Old 10-29-2007, 02:18 AM   #4
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by Bruce Hill View Post
Assuming you mean about:config such as Firefox's, where in Thunderbird would that be located?
Edit > Preferences > Advanced > General Tab > Config Editor button
 
Old 10-29-2007, 02:21 AM   #5
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Have you tried copying the .wav file from your XPee partition to your ~ and select/add it from there?
 
Old 10-29-2007, 02:33 AM   #6
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Original Poster
Rep: Reputation: 128Reputation: 128
Thunderbird won't play anything from XP because it's a read-only partition with these perms:
Code:
root@wired_silas:~# ls -alh /WinXP/
total 1.6G
dr-x------  1 root root 8.0K 2007-10-19 18:41 ./
So, yes, I copied it to ~/ and changed it's perms to 644, just like the KDE sound file:
Code:
mingdao@wired_silas:/usr/share/sounds$ ls -lh ~/ringin.wav
-rw-r--r-- 1 mingdao users 9.8K 2007-10-20 20:49 /home/mingdao/ringin.wav
mingdao@wired_silas:/usr/share/sounds$ ls -lh KDE_Startup.wav
-rw-r--r-- 1 root root 357K 2005-09-10 16:25 KDE_Startup.wav
I did find the about:config, but don't see what to change. Searching it for sound, it has:
Code:
accessibility.typeaheadfind.enablesound     default     boolean     true
accessibility.typeaheadfind.soundURL     default     string     beep
mail.biff.play_sound     default     boolean     true
mail.biff.play_sound.type     user set     integer     1
mail.biff.play_sound.url     user set     string     file:///usr/share/sounds/KDE_Startup.wav
What, if anything, would I change there?
 
Old 10-29-2007, 02:42 AM   #7
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by Bruce Hill View Post
Code:
accessibility.typeaheadfind.enablesound     default     boolean     true
accessibility.typeaheadfind.soundURL     default     string     beep
mail.biff.play_sound     default     boolean     true
mail.biff.play_sound.type     user set     integer     1
mail.biff.play_sound.url     user set     string     file:///usr/share/sounds/KDE_Startup.wav
What, if anything, would I change there?
This is a stretch but give it a shot.........

Add the .wav file you want to use, again. Close Thunderbird then restart, go to about:config to see if it is listing the correct file.

If it does not show up correctly, manually enter the the correct location.

I'm no expert, just trying to trouble shoot it, it's a shot in the dark but I have seen stranger. Other than that, I am clueless...............Chok Dee (Good Luck)
 
Old 10-29-2007, 02:51 AM   #8
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Start T-Bird from Konsole after you have set the sound event with the problem .wav file, send yourself an e-mail and see if an error is generated, that may help pinpoint the problem.
 
Old 10-29-2007, 02:59 AM   #9
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Original Poster
Rep: Reputation: 128Reputation: 128
Since you're trying to help I did that ... again ... with no change in the aberrant behavior.

Changing the sound application used is what I'd like to try, but don't know how to do that. IMO it's more related to Slackware-12.0 than Thunderbird, since Thunderbird-1.5.0.7 in Slackware-11.0 (and earlier versions in the app and OS) didn't have this problem.

I had also tried starting it from CLI before, with nothing appearing in stdout with any sound file selected.
 
Old 10-29-2007, 03:05 AM   #10
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Peoples Republic of Kalifornia
Distribution: Slackware64 Current
Posts: 1,038

Rep: Reputation: 127Reputation: 127
Well, guess you can try the Mailbox Alert Extension......I'm reaching...

https://addons.mozilla.org/en-US/thunderbird/addon/2610
 
Old 10-29-2007, 03:11 AM   #11
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: McCalla, AL, USA
Distribution: Gentoo (all servers at work are openSUSE)
Posts: 6,938

Original Poster
Rep: Reputation: 128Reputation: 128
That one comes up empty. It doesn't change the sound app, only allows you to give different sounds for different mailboxen.
 
Old 11-01-2007, 07:09 PM   #12
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
I have moved this thread to Linux-Software
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound won't play in Slackware 11.0 thethinker Slackware 15 05-08-2007 09:50 AM
How do I properly install Thunderbird paultaylor Linux - Software 5 01-25-2005 07:40 PM
Thunderbird 0.8 not working properly aeruzcar Linux - Software 2 09-24-2004 03:15 AM
how to play sound file with c code? khucinx Programming 1 05-11-2004 07:28 AM
unable to play more than one sound file at a time. wonka_vision Linux - Hardware 2 06-10-2003 07:22 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration