Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 03-13-2005, 05:02 PM   #1
Jitan Forcier
LQ Newbie
Registered: Mar 2005
Distribution: FC3
Posts: 4

Rep: Reputation: 0
Themes GTK+ PLZ HELP!!!

I'm kinda new to linux... But yet, I managed to do well and do stuff around with it... I had no problem, since I tried to install a GTK theme...
I first tried to hit the install theme button in Applications/settings/themes
but I noticed that it wasn't working
(my theme is a complete theme with a gtkrc file)
so I looked around on the web and found a guide that told me to edit the .gtkrc-1.2-gnome2 file in my personal folder. So I did. I changed the theme to "/usr/share/themes/BHgtk/gtk/gtkrc"
I saved the file and opened some prog around to see if it worked. Some of the progs I opened were using the theme, but some were not. Actually, The theme was like 50% used (only the content of some progs were using it and the window border was still the default one)
So I told to myself: "maybe I need to reboot so it could use all of it" and I did.
But when I came back the .gtkrc-1.2-gnome2 file was back to normal (default) ...
I tried again and every time I reboot it get back to default... I tried as a root, does the same...
So I ask here, to u guys, gods of unix :P how could I change my current theme to /usr/share/themes/BHgtk/gtk/gtkrc ?

Last edited by Jitan Forcier; 03-13-2005 at 05:22 PM.
Old 03-13-2005, 05:40 PM   #2
Senior Member
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
If you're using gnome then just use the 'theme' setting in the gnome-control-center to set it. If not, then edit the file:

.gtkrc (in your home folder)
and have the line:
include "/usr/share/themes/Milk\ 2.0/gtk-2.0/gtkrc"
as the only thing in it. (note, Milk 2.0 is the theme I'm using...the \ is because the name contains a space). Also, that will only change the theme for programs using the old gtk 1.2. Most programs now use gtk 2.0 (or higher). You can change this in the file .gtkrc-2.0

My solution is simply to have .gtkrc-2.0 as a symlink to .gtkrc
You can even change the default font by also adding the line:
gtk-font-name "Runoff 14"
(where runoff is the font name and 14 is the size). Use the font names exactly (capitalisation and all) as they appear in GIMP's font selector. Prefix all spaces with a backslash \


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
GTK Themes Cryptix Linux - Software 4 05-11-2005 07:40 PM
something about the gtk themes linjia Linux - Software 0 10-28-2004 11:23 AM
kde themes looking like gtk themes mokojin Linux - General 1 09-21-2004 03:09 AM
gtk themes thundershtorm Linux - Software 3 09-14-2004 07:30 AM
Switching GTK 2 themes atheist Debian 4 06-07-2004 05:54 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:58 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration