LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-30-2003, 10:53 PM   #1
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Rep: Reputation: 15
The sound of silence...


Okay, I maybe a stupid one with this, but I didn't figured it out yet......I have absolutely no sound on my RH 9 system since I installed it!
I've tried several things, such as redhat-system-soundcard detection and kudzu but to no avail....I'll post my /etc/modules.config files in the hope to make some clear:

alias usb-controller usb-ohci
alias eth0 ne2k-pci
alias usb-controller usb-ohci
alias usb-controller usb-ohci
alias usb-controller usb-ohci
alias usb-controller usb-ohci
alias sound-slot-0 emu10k1
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :

I have a creative 5.1 soundblaster live! soundcard.

I really hate working without sound, it's like I am deaf or something
I hope someone can help me here!
 
Old 06-30-2003, 11:34 PM   #2
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Did you check your mixer prog? Many distros mute the sound by default, try opening up kmixer in KDE, or whatever the mixer app is in Gnome (I have no idea, I last used Gnome about 3 years ago).
 
Old 07-01-2003, 12:22 AM   #3
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
WTF?!?

Indeed, it was set to mute! So I activated the sound (via redhat-settings-sound).....but still nothing happens!
I still live in the sound of silence! (kewl song but quite idiot in Linux )
grtz
 
Old 07-01-2003, 06:14 AM   #4
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Maybe you should check out ALSA to see if your soundcard is supported via their drivers.
 
Old 07-01-2003, 04:55 PM   #5
mike L
Member
 
Registered: May 2001
Distribution: SuSE 10 (SLED)
Posts: 30

Rep: Reputation: 15
I'm running SuSE 8.0 and it found my S.B. live card right away, do you have "plug and play OS" selected to no in your bios?

just a thought.
 
Old 07-02-2003, 05:35 AM   #6
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Yes, no plug and pray here and the ALSA? Well, they say that I should use EMU10k1 as my sound module, well I have that module (see above).
So, this isn't the solution?

Please share some more thoughts with me

Edit:
I think there is something wrong with the last line of my modules.config which says: pre-remove <-- that isn't good in my opinion
But let me hear your opinions about this aswell!

Last edited by Q-collective; 07-02-2003 at 05:38 AM.
 
Old 07-02-2003, 05:43 AM   #7
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
Try this series of commands:

killall esd
cat /dev/urandom >/dev/dsp

(hit ctrl-c to end)

do you hear anything?
 
Old 07-02-2003, 05:49 AM   #8
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by mhearn
Try this series of commands:

killall esd
cat /dev/urandom >/dev/dsp

(hit ctrl-c to end)

do you hear anything?
I'm still a n00b at this, were do I have to input that? And how? Do I need the root password?
I'm a ... please treat me as one
 
Old 07-02-2003, 10:01 AM   #9
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
Type them into a terminal window after switching to root with the `su` command.
 
Old 07-02-2003, 07:27 PM   #10
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Well, If I type in: killall esd cat /dev/urandom >/dev/dsp (at one line yes)
I get:"Unkown file"
If I type in killall esd /dev/urandom >/dev/dsp (so without the cat) I get :"no processes killed"
Am I doing something wrong in here?
Thank you
 
Old 07-03-2003, 11:04 AM   #11
mrtwice
Member
 
Registered: Feb 2002
Distribution: xubuntu 8.10
Posts: 225

Rep: Reputation: 31
yes, you are doing something wrong. They are two seperate commands:

killall esd

Then hit return. Now type

cat /dev/urandom >/dev/dsp
 
Old 07-05-2003, 01:14 AM   #12
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Ok, now I'm getting an error: Error with writing: unknown device

I typed it in correctly and apart this time

ps: I'm reacting a little slow due to my shortness in time, I'm sorry for that.
 
Old 07-05-2003, 04:38 AM   #13
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I don't know but try disable
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
by putting # in front of each line.

Have a look at
http://www.alsa-project.org/alsa-doc...module=emu10k1

Add the lines mention in "Setting up modprobe and kmod support". If you want to understand where to get the values for sound-service. You can check in /proc (I think).
 
Old 07-05-2003, 09:42 AM   #14
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Thank you for that support, I'll try it out!
 
Old 07-27-2003, 09:17 PM   #15
Q-collective
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Gentoo, obviously
Posts: 113

Original Poster
Rep: Reputation: 15
Poeh! That was a long time ago.......time is a precious thing....

But I tried out what Electro said but nothing happened.....pitty enough

Does anyone else still got an idea?
It would be greatly appreciated!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
changelog silence davidsrsb Slackware 8 03-28-2005 08:35 AM
...and then there was silence ThreeGreen Linux - Hardware 7 12-14-2004 02:23 PM
Problem CD-Ripping - only silence kuddel Linux - Software 2 10-08-2004 06:35 AM
A way to make PAM to run in silence Half_Elf Linux - General 6 08-05-2003 10:29 PM
the module is there, but the silence goes on kev0lush Slackware 6 02-27-2003 01:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration