-   Linux - Software (
-   -   The Chicken and the Egg... (

ButterflyMelissa 09-04-2011 07:51 AM

The Chicken and the Egg...

Okay, in my personal timezone, it's sunday, and since I dont have anything better to do, I decided to give something zany a whack: install Linux from GNU source.
Okay, I've gotten this far: got a 16Gb USB stick partitioned, and mounted, the networking works so I can wget anything.
Snag, I will need GCC...but GNU delivers ... source (unless I'm wrong, if so correct me), so, how to I compile something without a ... compiled compiler?
Oh, if I can untar everything, I get a "invalid tar magic" when I try to unpack make...

Any thoughts? Thanks!


Edit : following the LFS roadsign, I use TTYLinux as base to start with...

repo 09-04-2011 08:30 AM

"ws TTYLinux" has GCC-based C development capability.

Kind regards

ButterflyMelissa 09-04-2011 08:36 AM

Thanks, I knew I missed something...

ButterflyMelissa 09-04-2011 09:52 AM

...oh great, now (just like the other ones) it does'nt get anything untarred,

upon arival:


tar xvzf bison-2.3.tar.gz
and I get


invalid tar magic
Though the "z" is a flag for gz files

I tried a woraround:


gunzip bison-2.3.tar.gz
tar xvf bison-2.3.tqr
with the same effect...

Hmm, weird...
Edit : according to the man page, the default download mode is "i" -, since I did'nt set the mode, the tars should not have been changed during transit...

repo 09-04-2011 10:13 AM

Could it be the tar file is corrupt?
What's the output from

file bison-2.3.tar.gz
Kind regards

ButterflyMelissa 09-04-2011 10:29 AM

Well...file does'nt work, so I did a "more" and it says nothing weird, all in all the tar scrolls by apparent damages...

Edit : I tried the very same on my system (wget and tar) and here the same file untars nicely...what is bizare is that I could wget ad untar gcc (though not needed, in hindsight) on the affected system without a glitch...
Edit : It is possible that the Busybox Tar is not that good...too bad that I have to give up for this :(

ButterflyMelissa 09-04-2011 02:20 PM

Confirmation : the Busybor Tar function does'nt work well on some/most tarballs...I'll try to install a GNU tar...

All times are GMT -5. The time now is 08:10 AM.