LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   tesseract stopped. error withut explanation. (https://www.linuxquestions.org/questions/linux-software-2/tesseract-stopped-error-withut-explanation-4175484632/)

littlejoe5 11-14-2013 09:00 PM

tesseract stopped. error withut explanation.
 
I like tesseract. I downloaded version 3.02, and started using it right away with excellent results. Then it stopped working, with the following error:
tesseract ltr-996h-p1.png ltr-996h-p1
Tesseract Open Source OCR Engine v3.02 with Leptonica
Cannot open input file: ltr-996h-p1.png

I was using the same programs to scan and prepare the png, or tif files (gimp and xsane). No description of what the error means. the help feature doesn't help, and man tesseract is no help either - maybe because I don't understand their termnology.

If you know where I should go from here, pleae help me out. Or maybe you now where there is some really thourough and understandable documentation on tesseract.

Thanks.

evo2 11-14-2013 10:13 PM

Hi,

I'd start by checking for the existence (and permissions) of that file.

Evo2.

knudfl 11-14-2013 10:24 PM

3.02 : An old version ? Ubuntu's 13.04 - 13.10 have `3.02.02'.
The 12.04 - 12.10 versions have tesseract`3.02.01'.

May be reinstall the package and its libraries :
$ sudo apt-get install --reinstall \
tesseract-ocr liblept3 libleptonica libtesseract3 \
tesseract-ocr-eng tesseract-ocr-equ tesseract-ocr-osd


Alternatively create a very small image by name "ltr-996h-p1.png".
And copy the image to "saved images" ( Wherever that is.)
I.e. tesseract has no system files by name ltr-996h-p1.png, AFAIK.

-

littlejoe5 11-15-2013 12:26 AM

Thanks for a quick reply. I'm anxious to get back to work with it. I've got a lot of papers that I wrote years ago, and have long since lost the digital files (through crashes, a stolen laptop, etc.)

The file named there is a name that I file that I named. It is a graphic file, a scan (cleaned up and trimmed in Gimp) of a printed page. It belongs to user #1000 (me) and is rw.

Mint13 Mate is the newest version that I have been able to get to run well on my computer, and tesseract`3.02.02 is the version that is in the repositories.

I tried to run the lengthy command as you typed it, and it appears that liblept3 can't be found in the repositories.

Ill try reinstalling what I can reinstall, and see if that helps. But (to me) the mystery of this lies in the fact that it was working just fine, and I did not change my methods, but it stopped. Unless, I may be leaving out an option in the command line? But I have been unable to find any adequate explanations about controlling it's operation from the command line.

Thanks so-o-o-o much. I reinstalled, and it appears that is just what it needed. Don't really know why, but it worked.


All times are GMT -5. The time now is 05:38 AM.