LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-15-2017, 07:09 PM   #1
treemouse
Member
 
Registered: Jan 2017
Posts: 30

Rep: Reputation: Disabled
Terminals have tiny font after changing video driver


I am running Debian Jessie 8.7, on a Lenovo ThinkPad E555.

By "terminals" I mean the command-line screens that you see whet you are NOT in X - eg. the ones you get to with alt+ctrl+F1, alt+ctrl+F2, etc. (I don't know if this is the correct term - if there's a better term, let me know!)

When I first installed Linux on this system, the terminals had a nice normal, readable font. After installing the non-free firmware for my Radeon card, the font for these got so small it is almost unreadable.

I would assume that this means that something is now detecting that it can display them at a higher resolution, and therefore is doing so. What is that "something", and where is its config file so I can make it stop doing that?

Edit:
I tried editing /etc/grub/defaults, setting GRUB_GFXPAYLOAD_LINUX="text", running update-grub, and rebooting - this did NOT solve the problem.

Last edited by treemouse; 01-15-2017 at 10:35 PM.
 
Old 01-15-2017, 11:14 PM   #2
Brains
Senior Member
 
Registered: Apr 2009
Distribution: Debian Testing, Gentoo
Posts: 1,293

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
Probably can set it to different resolution in a graphical terminal by editing /etc/default/grub file. The code below is a section of this configuration file with a resolution of 640x400 but it is currently not set, to set it, remove the hash at start of the line highlighted in blue, change the resolution to what you want.
Code:
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
Run command: update-grub as sudo or root after editing this file.

EDIT: I don't have a grub directory in /etc. Things might be a little different with Debian testing. So you should be able to use that setting in you defaults file.

Last edited by Brains; 01-15-2017 at 11:21 PM. Reason: Added info regarding my Debian Stretch
 
Old 01-16-2017, 12:26 AM   #3
treemouse
Member
 
Registered: Jan 2017
Posts: 30

Original Poster
Rep: Reputation: Disabled
Thank you Brains!


For anybody who Googles across this thread later, here are some other solutions I found too:

1. Use the kernel options "nomodeset nofb" at boot (set in /etc/default/grub under GRUB_CMDLINE_LINUX_DEFAULT). This disables the framebuffer, and gives you the classic 80x25 character text terminal. Unfortunately, it is not currently possible to turn off the framebuffer without also turning off KMS (Kernel Mode Setting), a feature of newer Linux kernels that lets the kernel control certain video settings. I'm not sure what all of the side-effects of disabling KMS with "nomodeset" are, but one is that you are no longer able to adjust the brightness of your laptop screen.

2. dpkg-reconfigure console-setup, which instead of changing the console resolution, let you pick a console font and size.

Last edited by treemouse; 01-16-2017 at 12:27 AM. Reason: Clarified relationship between KMS and framebuffer
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Emacs - changing default font size and font type? neilcpp Linux - Software 16 05-20-2013 11:29 AM
Changing Video Driver and Screen Resolution kaplan71 Debian 4 12-22-2005 09:47 AM
changing video card driver jwstric2 Fedora 2 05-03-2005 07:55 PM
changing video driver via command line armus513 Mandriva 4 02-04-2005 11:03 AM
Problem with Font after installing new Video Driver hari_seldon99 Linux - Software 0 02-05-2004 08:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration