LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   telnet localhost 25 trouble (https://www.linuxquestions.org/questions/linux-software-2/telnet-localhost-25-trouble-279623/)

papitu76 01-19-2005 04:56 AM

telnet localhost 25 trouble
 
I am having trouble when i do
telnet localhost 25

I get the following answear:

webMailServer:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.

Why i am not able to see enything else as is described in the http://www.qmailrocks.org/start_qmail.htm. I have to say i have followed the instructions of that howto.

This are all the information i guess it can be interesting.

webMailServer:~# sh netstat-lp-grep-smtp.sh
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
tcp 0 0 *:ssmtp *:* LISTEN 309/inetd
tcp 0 0 *:smtp *:* LISTEN 309/inetd


rec-palvarez@webMailServer:~$ qmailctl stat
/service/qmail-send: unable to open supervise/ok: access denied
/service/qmail-send/log: unable to open supervise/ok: access denied
/service/qmail-smtpd: unable to open supervise/ok: access denied
/service/qmail-smtpd/log: unable to open supervise/ok: access denied
/service/qmail-pop3d: unable to open supervise/ok: access denied
/service/qmail-pop3d/log: unable to open supervise/ok: access denied
find: queue/mess/*: Permission denied
find: queue/todo: Permission denied
messages in queue: -1
messages in queue but not yet preprocessed: -1
rec-palvarez@webMailServer:~$


rec-palvarez@webMailServer:~$ telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Qpopper (version 4.0.4) at webMailServer starting. <9471.1106131172@webMailServer>
And i am avaible to enter and user ans see its mails.




webMailServer:~#ps -aux|grep smtp

Bad syntax, perhaps a bogus '-'?
root 688 0.0 0.4 1240 292 ? S Jan18 0:01 supervise qmail-smtpd
qmaill 698 0.0 0.4 1252 280 ? S Jan18 0:00 multilog t s100000 n20 /var/log/qmail/qmail-smtpd
root 5582 0.0 0.7 1340 472 pts/0 S 11:28 0:00 grep smtp

webMailServer:~# ps -aux|grep qmail

Bad syntax, perhaps a bogus '-'?
root 686 0.0 0.0 1240 60 ? S Jan18 0:00 supervise qmail-send
root 688 0.0 0.1 1240 64 ? S Jan18 0:01 supervise qmail-smtpd
root 690 0.0 0.1 1240 64 ? S Jan18 0:00 supervise qmail-pop3d
qmails 695 0.0 0.2 1320 184 ? S Jan18 0:01 qmail-send
qmaill 696 0.0 0.0 1260 60 ? S Jan18 0:00 multilog t s100000 n20 /var/log/qmail/qmail-send
qmaill 698 0.0 0.0 1252 0 ? SW Jan18 0:00 [multilog]
qmaill 700 0.0 0.1 1260 124 ? S Jan18 0:00 multilog t s100000 n20 /var/log/qmail/qmail-pop3d
root 703 0.0 0.1 1256 72 ? S Jan18 0:00 qmail-lspawn ./Maildir
qmailr 704 0.0 0.1 1256 108 ? S Jan18 0:00 qmail-rspawn
qmailq 705 0.0 0.0 1248 40 ? S Jan18 0:00 qmail-clean
root 7132 0.0 0.7 1340 472 pts/0 S 11:32 0:00 grep qmail

webMailServer:~# ps -aux|grep sendmail does nothing

My /etc/inet.conf

# /etc/inetd.conf: see inetd(8) for further informations.
#
# Internet server configuration database
#
#
# Lines starting with "#:LABEL:" or "#<off>#" should not
# be changed unless you know what you are doing!
#
# If you want to disable an entry so it isn't touched during
# package updates just comment it out with a single '#' character.
#
# Packages should modify this file by using update-inetd(8)
#
# <service_name> <sock_type> <proto> <flags> <user> <server_path> <args>
#
#:INTERNAL: Internal services
#echo stream tcp nowait root internal
#echo dgram udp wait root internal
#chargen stream tcp nowait root internal
#chargen dgram udp wait root internal
discard stream tcp nowait root internal
discard dgram udp wait root internal
daytime stream tcp nowait root internal
#daytime dgram udp wait root internal
time stream tcp nowait root internal
#time dgram udp wait root internal

#:STANDARD: These are standard services.
#<off># ftp stream tcp nowait root /usr/local/sbin/vsftpd vsftpd

#:BSD: Shell, login, exec and talk are BSD protocols.

#:MAIL: Mail, news and uucp services.
imap2 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/imapd
imap3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/imapd
pop-3 stream tcp nowait root /usr/sbin/tcpd /usr/sbin/in.qpopper -f /etc/qpopper.conf

This three following lines were pointing to sendmail, and they were #<off>#
I have chjanged the parameters and enable them.

smtp stream tcp nowait root /usr/sbin/sendmail qmail
587 stream tcp nowait root /usr/sbin/sendmail qmail
smtps stream tcp nowait root /usr/sbin/sendmail qmail


#:INFO: Info services
ident stream tcp wait identd /usr/sbin/identd identd

#:BOOT: Tftp service is provided primarily for booting. Most sites
# run this only on machines acting as "boot servers."

#:RPC: RPC based services

#:HAM-RADIO: amateur-radio services

#:OTHER: Other services
linuxconf stream tcp wait root /bin/linuxconf linuxconf --http
#<off># netbios-ns dgram udp wait root /usr/sbin/tcpd /usr/sbin/nmbd -a
#<off># netbios-ssn stream tcp nowait root /usr/sbin/tcpd /usr/sbin/smbd
391002/1-2 stream rpc/tcp wait root /usr/sbin/famd fam
#<off># swat stream tcp nowait.400 root /usr/sbin/tcpd /usr/sbin/swat

#<off># kshell stream tcp nowait root /usr/sbin/tcpd /usr/lib/kerberos4kth-servers/rshd -k
#<off># telnet stream tcp nowait root /usr/sbin/tcpd /usr/lib/kerberos4kth-servers/telnetd -a none



If is needed more information i will post as request.

Many thanks

david_ross 01-19-2005 02:51 PM

It looks like you haven't set the permissions correctly on the queue or log directories.

papitu76 01-20-2005 05:45 AM

Quote:

Originally posted by david_ross
It looks like you haven't set the permissions correctly on the queue or log directories.
Could you please detail more what files i should check? The ones i have been are in the /service and they are with root. I guess its right. I dint changed them. This directoy is created in the installation and gets the permissions there.

david_ross 01-20-2005 02:55 PM

The queue is usually:
/var/qmail/queue

And the logs are usually:
/var/qmail/log

Can you post the output of "ls -l" on each of those directories and /var/qmail

papitu76 01-21-2005 04:58 AM

webMailServer:/var/qmail# ls -la
total 48
drwxr-xr-x 11 root qmail 4096 Jan 17 19:14 .
drwxr-xr-x 17 root root 4096 Jan 12 13:33 ..
drwxr-sr-x 2 alias qmail 4096 Jan 17 19:30 alias
drwxr-xr-x 2 root qmail 4096 Jan 17 19:14 bin
drwxr-xr-x 2 root qmail 4096 Jan 12 18:28 boot
drwxr-xr-x 2 root qmail 4096 Jan 17 19:14 control
drwxr-xr-x 2 root qmail 4096 Jan 12 18:28 doc
drwxr-xr-x 10 root qmail 4096 Jan 12 18:28 man
drwxr-x--- 11 qmailq qmail 4096 Jan 12 18:28 queue
-rwxr-xr-x 1 root root 107 Jan 17 19:14 rc
drwxr-xr-x 5 root root 4096 Jan 12 13:34 supervise
drwxr-xr-x 2 root qmail 4096 Jan 17 17:45 users

webMailServer:/var/qmail/queue# ls -la
total 44
drwxr-x--- 11 qmailq qmail 4096 Jan 12 18:28 .
drwxr-xr-x 11 root qmail 4096 Jan 17 19:14 ..
drwx------ 2 qmails qmail 4096 Jan 21 10:50 bounce
drwx------ 213 qmails qmail 4096 Jan 12 18:28 info
drwx------ 2 qmailq qmail 4096 Jan 21 10:50 intd
drwx------ 213 qmails qmail 4096 Jan 12 18:28 local
drwxr-x--- 2 qmailq qmail 4096 Jan 12 18:28 lock
drwxr-x--- 213 qmailq qmail 4096 Jan 12 18:28 mess
drwx------ 2 qmailq qmail 4096 Jan 21 10:50 pid
drwx------ 213 qmails qmail 4096 Jan 12 18:28 remote
drwxr-x--- 2 qmailq qmail 4096 Jan 21 10:50 todo

And you can see i hacve no /var/qmail/log

Could be taht the reason?

Donboy 01-24-2005 08:44 AM

Try running your commands as root and see if that helps any. It looks like you're running them as an unpriv user.

papitu76 01-25-2005 06:49 AM

Quote:

Originally posted by Donboy
Try running your commands as root and see if that helps any. It looks like you're running them as an unpriv user.
Everythins is run either as a root or superuser. But the kye is that ther port 25 isnt listening but the qmailctl stat says that qmail is working. Otherwise the port 110 is lisenting.

And if i reboot the system qmail start alone, but i toke off every reference to it in the inetd.conf.

How does it start running?

Donboy 01-25-2005 08:00 AM

How did you check to see if qmail is listening on port 25? I prefer netstat -nap and check for services on port 25 that way.

qmail runs from /etc/inittab. Open this up and you should see a line like this...

SV:123456:respawn:/command/svscanboot

This is telling the system to start svscanboot, which (ultimately) loads everything under your /service directory, which includes qmail. Are you trying to prevent qmail from starting up on boot? Or just curious about how it works?

mzainkiani 12-23-2008 02:42 AM

Telnet example.com 110
 
Hello Alls

i am a new commer in Linux answers.org

question is

please tel me all commands using in " Dovecot "

to delete the mail and etc.
i will very thankfull to you.

repo 12-23-2008 03:21 AM

Quote:

Hello Alls
i am a new commer in Linux answers.org
question is
please tel me all commands using in " Dovecot "
to delete the mail and etc.
i will very thankfull to you.
Hi,

Welcome to LQ
Please start a new treath, do not use another treath to ask questions.

Thank you


All times are GMT -5. The time now is 08:11 PM.