LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-18-2017, 12:27 AM   #1
aidin8790
LQ Newbie
 
Registered: Apr 2014
Posts: 29

Rep: Reputation: Disabled
tcpreplay


Hi..

I want to use tcpreplay with packet sending rate 400Mbps.
this tools have --Mbps option sending rate.
but when I set it to for example 400Mbps , after sending packet and in the report of tools, the packet rate sending is different (such as attachments screenshot).
may you help me?

thanks..

http://www.linuxquestions.org/questi...1&d=1484717164
Attached Thumbnails
Click image for larger version

Name:	tcpreplay.JPG
Views:	13
Size:	29.3 KB
ID:	23997  
 
Old 01-18-2017, 05:28 PM   #2
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 639

Rep: Reputation: 189Reputation: 189
This is a stab in the dark as I have no experience with tcpreplay, but reading the tcpreplay man pages for --mbps (-M) option, it says
Quote:
"Specify a floating point value for the Mbps rate that tcpreplay should send packets at."
So you might try 400.0, rather than 400

EDIT: Scratch that. Just did a little testing and that made no difference.

I've only skimmed it, however, you might find this helpful


EDIT #2: I've been playing around with tcpreplay a bit. Are you trying to run this command on your currently connected interface? I believe you need one that is not being used. I tried this on a secondary usb wireless dongle and the -M option works as expected.

Code:
tcpreplay -i wlp0s20u1 -K -M 400 ~/test.pcap 
File Cache is enabled
Actual: 31536 packets (29575198 bytes) sent in 0.591504 seconds.
Rated: 49999996.6 Bps, 399.99 Mbps, 53314.93 pps
Flows: 301 flows, 508.87 fps, 31317 flow packets, 219 non-flow
Statistics for network device: wlp0s20u1
	Attempted packets:         31536
	Successful packets:        31536
	Failed packets:            0
	Truncated packets:         0
	Retried packets (ENOBUFS): 0
	Retried packets (EAGAIN):  0

Last edited by TheEzekielProject; 01-18-2017 at 07:43 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
tcpreplay help: raynet11 Linux - Networking 0 05-14-2004 10:47 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration