LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   tclerror: unknown color name "black" (https://www.linuxquestions.org/questions/linux-software-2/tclerror-unknown-color-name-black-767099/)

KirkD 11-05-2009 11:34 AM

tclerror: unknown color name "black"
 
I have just installed CentOS 5.4 and one of the applications I'm trying to run is PyMol - a molecular visualization tool - and when I start it I get a Python error that terminates with "Tclerror: unknown color name black" This particular application has two windows, a view window and a TCL/TK window that provides menus, and action buttons. The view window shows up but the Tcl/Tk window does not.

I have another application that gives a similar error: "tclerror: unknown color name grey90" This application does load and run, but it is a much more complex app that is likely only partially hindered. I haven't found yet how this one fails.

It seems to me that I don't have tcl/tk installed, configured, or enabled correctly, but I have no idea how to test this or how to troubleshoot the problems.

Any advice is greatly appreciated!

-Kirk

UPDATE::

I did

yum install tcl tcl-devel tk tk-devel

and indeed the tcl-devel package was not there. All the others were there and latest version.

When I tried

$ wish
% pack [label .m -bg "grey90" -fg "black" -text "hello" -width 10 -height 3]


I got the window but upon executing the pack line, I received an error stating: unknown color name "grey90" I also tried "gray90" and just making it "black" on "black" Each time I received an unknown color name error.

We seem to have found the problem - any suggestions on how to fix it?

Jim Bengtson 11-05-2009 11:51 AM

Apparently "black" and "grey90" are not standard colors in PyMOL:
http://pymol.sourceforge.net/newman/...mds.html#6_3_2

KirkD 11-05-2009 12:44 PM

Solved
 
I figured it out. In my xorg.conf file, the parameter RgbPath was set incorrectly. I did a global find to locate the rgb.txt file and set RgbPath appropriately. All is well now.

KirkD 11-05-2009 12:46 PM

Jim,

You are correct about PyMol standard colors but that is from the command line within the PyMol viewer. The error was actually coming from the underlying Python code itself. See my other post for my solution.

-Kirk


All times are GMT -5. The time now is 09:46 PM.