LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-20-2017, 06:08 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
tar.gz UTF-8 error cannot convert to current locale


so yeah, that is an error I am getting when trying to untar this tar.gz

my Local is set to

en_US

the error reads
Code:
The archive reading failed with the following error:
Pathname can't be converted from UTF-8 to current locale
is there a way to fix that?

Quote:
userx%slackwhere ⚡ ~ ⚡> locale
LANG=en_US
LC_CTYPE="en_US"
LC_NUMERIC="en_US"
LC_TIME="en_US"
LC_COLLATE=C
LC_MONETARY="en_US"
LC_MESSAGES="en_US"
LC_PAPER="en_US"
LC_NAME="en_US"
LC_ADDRESS="en_US"
LC_TELEPHONE="en_US"
LC_MEASUREMENT="en_US"
LC_IDENTIFICATION="en_US"
LC_ALL=
This is Slackware BTW

if I change this locale file

Code:
  nano 2.6.0             Bestand: /etc/profile.d/lang.sh  


# en_US is the Slackware default locale:
export LANG=en_US

                      

#
# LANG=<locale> locale -k charmap
#
# UTF-8 locales will include "UTF-8" in the output.
#
export LANG=en_US.UTF-8
as this first line was uncommitted.
1
Quote:
export LANG=en_US
to set it UTF-8
2
Code:
export LANG=en_US.UTF-8
should that first one be commented out to avoid conflict or can they both 1, and 2, be exported at the same time?

Last edited by BW-userx; 04-20-2017 at 06:28 PM.
 
Old 04-20-2017, 07:28 PM   #2
astrogeek
Moderator
 
Registered: Oct 2008
Distribution: Slackware [64]-X.{0|1|2|37|-current} ::12<=X<=14, FreeBSD_12{.0|.1}
Posts: 5,617
Blog Entries: 11

Rep: Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655Reputation: 3655
I would comment out the first one for clarity, but I think that only the last one in the file will have any effect.

It is setting an environment var named LANG, so first one sets it, then the second one immmediately resets it to another value.

Last edited by astrogeek; 04-20-2017 at 07:32 PM.
 
Old 04-20-2017, 07:50 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,952

Original Poster
Rep: Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148Reputation: 2148
Quote:
Originally Posted by astrogeek View Post
I would comment out the first one for clarity, but I think that only the last one in the file will have any effect.

It is setting an environment var named LANG, so first one sets it, then the second one immmediately resets it to another value.
YEA!!

that fixed it.
Code:
userx%slackwhere ⚡ ~ ⚡> locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE=C
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken characters in X with UTF-8 locale after 20161031 current update yenn Slackware 4 11-06-2016 04:25 PM
[SOLVED] UTF-8, not utf-8 or utf8 in locale setting to have SCIM working? Didier Spaier Slackware 8 10-16-2015 01:56 AM
Re: Locale problem: Can't convert string from native encoding to 'UTF-8' treotan Ubuntu 1 11-14-2007 08:02 AM
X11 / UTF-8 locale seems missing 'fr_FR.UTF-8' chrsitophermann Debian 11 07-17-2004 02:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration