-   Linux - Software (
-   -   System freezes when switching back to X11 (from console) while using DRI (

GamerX 12-05-2006 02:58 PM

System freezes when switching back to X11 (from console) while using DRI
Here's the lay of the land:

CPU: P4 2.8GHz (single core, non-hyper threaded)
GPU: ATI Radeon X800 GTO (AGP) (ATI's proprietary driver installed)

Default xwm is Xfce 4.2.0 (stock from Slackware 11.0 distro), I have "Launch KDE Services on startup" enabled (to use konqeror and amarok). No artifacts or problems while using X, thus far at least.
The problem is when I Ctrl + Alt + F1...6 to a console everything works like it should I can switch between the 6 consoles, however when I try to Ctrl + Alt + F7 back into X the system hangs. I get a black screen and no response to keyboard commands (3 finger salute, etc...) and my monitor's info box shows this black screen is running 720x400 resolution, same as the console (X runs at 1280x1024).

I'm 99.99% certain this has something to do with DRI being enabled because I've never had this problem when it wasn't working. The only way I can continue in this situation is to do a hard reset, and does that mean any error logs won't have a change to get written?

Is this a familiar issue to anyone? at least where should I be looking?

StargateSteve 12-05-2006 06:22 PM

Try disabling the proprietary driver, and using the open-source one. that solved the problem for me. And then get an nVidia card. ;)

GamerX 12-07-2006 12:23 AM

Hmm where would I find this other driver? Or which one did you mean in particular?

StargateSteve 12-08-2006 05:47 PM

The other driver should have come with Xorg. Try changing the Driver entry in your xorg.conf to "ati", after removing the proprietary one.

GamerX 12-10-2006 03:47 PM

Hmm well I tried using "radeon" and "ati" as the device drivers, but neither one works and X, after showing a couple of warnings, defaults to use the "Standard VGA" device which obviously doesn't give me DRI... And if I comment out that device then X dies saying it can't find a working device.
"fglxr" works as a driver though... I'll stick with it for now.

Also, these changes to xorg.config don't seem to take effect until I reboot the system, is there a script that will do this?

StargateSteve 12-11-2006 09:55 AM

The changes should take effect as soon as you restart X.

farslayer 12-11-2006 10:09 AM

When you view your Xserver log do you see a warning similar to this ?

cat /var/log/Xorg.0.log | grep WW

(WW) RADEON(0): Direct Rendering is disabled by default on Radeon VE/7000 hardware due to instability, but has been forced on with "Option "dri" in xorg.conf. You may experience instability.
Disable the dri module from loading and the lockups should go away..

Here is another thread where we were troubleshooting a very similar issue. commenting out dri from the Modules sections appears to have fixed the issue for this user.

GamerX 12-11-2006 03:12 PM

Yes that's correct if I comment out the "dri" module the problem goes away.
I also checked those 2 logs but didn't find anything suspicious, and Radeon 7000 series is a lot older than the X800 so I doubt it would be applicable.

But reading that other thread gives me an idea. The refresh rates may be incorrect for the monitor so it might be dying while trying to change video modes.

But it seems very strange that it would cause the kernel to stop responding all together, I tried pinging the computer while it's frozen and it's dead.

GamerX 12-11-2006 09:42 PM

Hmm no dice with the refresh rates, they were a bit off spec, however doesn't make a difference with this problem :(

Just a note, this happens for regular users AND root...

farslayer 12-11-2006 10:05 PM

Another interesting note..


Option "AGPFastWrite" "boolean"
Enable AGP fast write. Enabling this option is frequently the cause of instability. Used only when the DRI is enabled. The default is off.

Option "AccelMethod" "string"
Chooses between available acceleration architectures. Valid options are XAA and EXA. XAA is the traditional acceleration architecture and support for it is very stable. EXA is a newer acceleration architecture with better performance for the Render and Composite extensions, but the rendering code for it is newer and possibly unstable. The default is XAA.

Option "DMAForXv" "boolean"
Try or don't try to use DMA for Xv image transfers. This will reduce CPU usage when playing big videos like DVDs, but may cause instabilities. Default: on.

Yes I know this man page is for the radeon driver not the proprietary one.. but its interesting how many options make the system unstable with that driver...

The Gentoo Wiki seems to have more current info on the ATI Driver and random lockups... definitely check out this link.. it's a bit more relative to your configuration.

Best of luck to ya.. please report back if you narrow down the issue to a specific cause.

GamerX 12-12-2006 12:04 AM

Interesting thing... if you look at "man radeon" it says after the Radeon 9500 series (R300 chip and onward) this driver only supports 2D acceleration and this appears true.

The options for radeon driver don't appear to be used/recognised by fglrx driver, however I tried disabling AGP Fast Write in my BIOS and got a marginal improvement!
Now the resolution switches to 1280x1024 and I can see the cursor against a black screen, but other than that the system is still frozen :\

There is no man pages or any sort of manual, or at least a list of options for the fglrx driver... which sucks.
The aticonfig utility is suposed to be used for that I guess.

All times are GMT -5. The time now is 07:57 PM.