-   Linux - Software (
-   -   System Commander wont boot RH 7.2 and Internet Problems (

offroad 10-31-2001 10:43 AM

System Commander wont boot RH 7.2 and Internet Problems
Just installed RH 7.2 (Intel), its on my first SCSI drive.
I have System commander on my first IDE drive that boots Win98 and XP on it.

I have installed a workstation load of RH and set it up using both Grub and Lilo on both the mbr and first sector of boot partition.

System Commander does not recognize RH. If I manually configure an entry for RH it still fails to boot.

Booting with a boot diskette is fine.

Also can't get the internet working under RH 7.2
I have used the internet wizard to configure a dialup connection. It appears to have TCP/IP asscociated and will connect to my ISP but browsers will not go anywhere.

Could a misconfiguration of RH's firewall be causing this? I followed the install guide and it seems ok.

Any advice or redirection to a more appropriate forum would be greatly appreciated.

michael_hoare 10-31-2001 09:51 PM

Internet problems
I had a similar problem with an earlier version of RedHat (I haven't used 7.2). Check /etc/resolv.conf for DNS (ensure same as windows setup.

Also check browser proxy settingd. I didn't have any trouble with a standard firewall setup set to "high" on RH7.1.

You might also check /var/log/messages when you log on - it should bring up DNS information as well as PPP.

If you are unsure as to whether you have a browser or DNS problem, or just a logon problem, see if email works, inwards and outwards. If email is functioning, most likely you have a DNS or proxy setup problem.

offroad 11-01-2001 10:44 AM

Internet Problems
Michael: I figured out the internet problem.

I had conifigured a dialup to my isp using the KPPP Dialer.
It didn't work and still doesn't (not sure whats up with it)

Good news is I set up another one with the RH Dialer and it
works fine. Browsing anywhere I want.

Still have the problem with System Commander not being able to boot RH.
System Commander is on my 1st IDE Drive (have two ide's)
And RH is on my 1st SCSI (sda, I have two scsi's)

I have installed RH about five times now trying to fix this, the last time I let System Commanders OS Wizard prepare sda, It partitions the drives a bit different than RH does.
I did change the install partition from ext2 to ext3, maybe this is the problem?

I am going to try one more install using System Commander's OS Wizard and leave the RH partition at ext2 if this doesn't work I am out of ideas.

offroad 11-02-2001 11:11 AM

Solved the System Commander Problem
I figured it out last night. Best I can tell System Commander has problems with the ext3 format that RH 7.2 wants to use.

If I let RH 7.2 handle the partitioning of my 2.1gb sda drive it sets up the following:

/boot -- 40mb ext3
/ -- 1700mb ext3
swap -- 400mb

If I change the format on the /boot partition to ext2 and set the boot loader to go on the first boot sector of sda I can use either Lilo or Grub (using Grub) and System Commander is able to boot RH 7.2 just fine.

I am using the latest version of System Commander v5.06
The tip off was when you went into System Commander to manually add an entry for RH 7.2 all of the sda partitions show as ext2 formatted even when they are really ext3.

System Commander does recognize the operating system as Linux but apparently can't really handle ext3 properly.
Hopefully they will release an update that will fix this.

I am going to forward this to them, RH 7.2 is very new and perhaps they were not aware of this. I'm new to Linux so I'm not sure how many other Distro's are using ext3 but if I'm not mistaken I think its a new feature in the latest Kernels?

All times are GMT -5. The time now is 01:08 AM.