-   Linux - Software (
-   -   Synergy/Synergy+ - "@" key problem (

eponymous 12-01-2009 07:32 PM

Synergy/Synergy+ - "@" key problem
Hi guys,

So here's the problem:

I've got a Windows 7 machine and a Gentoo 10.1 box set up with Synergy keyboard and mouse sharing configured.

The Windows 7 keyboard and mouse is shared with the Linux box so I can control the Linux box from windows.

I've set the keyboard language on both machines to be English (UK) with a Generic 105 key layout.

However, when I try and type "@" which is [Shift + '] on my keyboard, I get a "?" on the screen in Linux and the caps lock key flashes for a second on the Linux keyboard.

If I change the layouts to be "default" instead of "Extended UK" I get my @ symbol working but I don't get the < > keys working - they are replaced with and I still get a caps lock flash for the @.

I've tried so many different things to get this to work and nothing :(

I'm using evdev for the keyboard driver and the keyboard I have connected to the Linux box is a really cheap 85 key keyboard (i.e. no numpad etc)

Does anyone have any ideas on this?


N3rding 12-08-2009 08:24 PM

Have you tried running the synergy server on the linux box and the client on your win box? I've been running that way for over a year with no issues...

All times are GMT -5. The time now is 01:53 AM.