-   Linux - Software (
-   -   synaptic problem (

automata 10-09-2007 10:47 AM

synaptic problem
fablab@fablab-desktop:/media/cdrom/archive/dists/fabber/restricted/binary-i386$ aptitude -f install fab-cam_0.4_all.deb
Segmentation fault (core dumped)

Now this is what I am getting when I am trying aptitude also my synaptic package manager is not opening.I have a live cd.Can i do something with that.I dont want to reinstall the system.If I do this I will be re installing for fourth time.

Also,I want to know that if discussion in any particular thread goes for more than 12 replies then are they neglected.



pljvaldez 10-09-2007 11:08 AM

Well, first off you can't install programs unless you are the root user. You either need to su to root or use sudo. Also, you can't use Synaptic without being root either.

Second, you can't use aptitude to install a plain *.deb file. You only use aptitude to install from a repository. Instead either add the CD to your repositories using the apt-cdrom command or install the *.deb with dpkg -i packagename. Note that the dpkg method won't handle dependencies for you.

What distro is installed on the hard drive? And what liveCD are you trying to use?

automata 10-10-2007 12:10 AM

I tried to open synaptic by being root but I got some errors. I was installing from synaptic few days earlier and then the machine hanged. I had to kill synaptic to bring my machine back to normal. After that point the synaptic and any installation command never worked. It always give me same error. Segmentation fault (core dumped).

I am using ubuntu 7.04 The fiesty fawn debian. I have a live CD of ubuntu 7.04. Is there any way I could repair the synaptic from it if it is broken.

pljvaldez 10-10-2007 11:00 AM

There might be a lock on the dpkg database. Try going to /var/cache/apt/archives and deleting the lock file. Then try running synaptic again.

automata 10-10-2007 11:08 AM

No I deleted the lock file but there was no change.Do I have any option of installing the synaptic if its broken from the live cd.


automata 10-18-2007 06:20 AM

Is anyone working on this post.Please I need this badly and the thing is that I am hopeful that I can do something with the LIVE CD.

Please help me with this.


pljvaldez 10-18-2007 10:40 AM

You can try sudo dpkg --configure -a, but I'm skeptical it'll work. I think you may have a mess on your hands....

Sorry I couldn't be more help.:cry:

pljvaldez 10-18-2007 10:46 AM

You can also try sudo dpkg --get-selections |grep -i broken and try to purge the broken packages.

All times are GMT -5. The time now is 07:12 PM.