-   Linux - Software (
-   -   synaptic package manager forcing me to delete a broken package (

mbman 04-14-2006 11:20 PM

synaptic package manager forcing me to delete a broken package
I recently installed a version of mozilla sunbird on my system that
despite being flagged for missing dependacies on install has worked fine, but now everytime I use the package manager it gives me a error detecting a broken package and will not let me install anything else unless I remove the broken sunbird package. Is there a way to get the synaptic package manager to ignore broken packages?

Using the 0.57.4 version with ubuntu 5.10


TuxSurfer 04-15-2006 09:26 AM

Check this...
"As APT is quite strict about the consistency of the system broken packages are not allowed (as well as broken rpm database entries).
In order to avoid such situations operations involving the RPM flags --force and --nodeps should be avoided. If however the system state is already inconsistent executing:

/usr/bin/apt-get check

will suggest a repair solution. One of most common problems is related to interrupted apt-get or rpm transaction (when the process was killed for example): such transcations may result in some duplicated packages. In order to fix the system duplicates shall be removed manually running

/usr/bin/apt-get remove packagename"

This is a quote from
Lots of useful info here, hope this helps. :)

berbae 04-15-2006 09:33 AM

What package(s) did you miss when you installed Mozilla Sunbird?
Can't you install those, to resolve the broken package which prevent you from using apt/synaptic?

mrcheeks 04-15-2006 10:22 AM

you can remove it and try :

apt-get install mozilla-calendar

mbman 04-15-2006 11:52 AM

missing packages
An apt-get check shows the following missing dependancies:

The following packages have unmet dependencies:
sunbird: Depends: libcairo2 (>= 1.0.2-2) but 1.0.2-0ubuntu1 is installed
Depends: libgcc1 (>= 1:4.0.2) but 1:4.0.1-4ubuntu9 is installed
Depends: libglib2.0-0 (>= 2.8.5) but 2.8.3-0ubuntu1 is installed
Depends: libpango1.0-0 (>= 1.10.2) but 1.10.1-0ubuntu1 is installed
Depends: libstdc++6 (>= 4.0.2-4) but 4.0.1-4ubuntu9 is installed
Depends: libxrender1 (>= 1: but 1:0.9.0-1 is installed
E: Unmet dependencies. Try using -f.

Any place I could pick up these supposedly needed packages as none of the repositories seem to have such up to date versions.

Or failing that a simple hack to keep apt-get quiet would be nice:)


berbae 04-16-2006 01:08 PM

From what you say, I deduce that you didn't use a Ubuntu rpm package to install Mozilla Sunbird, and you installed it outside apt/synaptic.
If that means that there doesn't exist a package for your distribution, it is generally not recommended to use packages for other Linux distributions.
So either you update the packages of your current distribution, but you say that it is not possible,
or you uninstall Mozilla Sunbird rpm package and you reinstall it, but with a compressed tar file instead (even compiling it yourself, if binary tar files are not available). So your rpm database will not be affected.
And generally it is preferable to follow the dependencies mentioned in README or INSTALL files.
These are general counsels because I don't use Ubuntu myself.
You may also write to Ubuntu forums to find more specific help for your distribution.
I hope you will find a solution to your problem.

Edit: You may also try the Smart package manager which seems to tolerate broken relations in installed packages. see Smart site

archtoad6 04-25-2006 10:30 AM

Am I missing something, since when is there such a thing as a "Ubuntu rpm package"?

All times are GMT -5. The time now is 02:55 PM.