LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-29-2015, 07:50 PM   #1
andrew.comly
Member
 
Registered: Dec 2012
Distribution: Trisquel-Mini 7.0, Lubuntu 14.04, Debian lxde 8.0
Posts: 308
Blog Entries: 2

Rep: Reputation: 16
Question Sylpheed: Can Send, can't receive


I have used the following procedure to set up a gmail account from sylpheed 3.4.1, but as a result I can only send email, and not receive email. Even though I am using lubuntu 14.04, still in the future I would like to use debian. Thus sylpheed is the choice email client.

Procedure:
1) I use synaptic package manager to download sylpheed and install.
Quote:
Start Sylpheed
Configuration > Create new account ... > IMAP4 gmail.
2) I then enter my name and full gmail address, including '@gmail.com'
On the last page it tells me my gmail address has been set up, verifying that
Code:
imap4 server: imap.gmail.com:993 (SSL)
smtp4 server: smtp.gmail.com:465 (SSL)
3) The rest is default, except I entered in my password under:
Quote:
Configuration > Preferences for current account > Basic > password(bottom right)
4) I configure my gmail settings at https://support.google.com/mail/trou...65018,1665144:
Quote:
Incoming Mail (IMAP) Server - Requires SSL
imap.gmail.com
Port: 993
Requires SSL:Yes
Outgoing Mail (SMTP) Server - Requires TLS
smtp.gmail.com
Port: 465 or 587
Requires SSL: Yes
Requires authentication: Yes
Use same settings as incoming mail server
Full Name or Display Name: [your name]
Account Name or User Name: your full Gmail address (username@gmail.com). Google Apps users, please enter username@your_domain.com
Email address: your full Gmail address (username@gmail.com) Google Apps users, please enter username@your_domain.com
Password: your Gmail password
5) Next from within firefox I configure my gmail:
Quote:
my account > sign in and security >
. a) Device activity & notifications > Recently used devices > Review Devices > Select unknown device > I marked this activity as "mine".
. b) Connected apps & sites (bottom) > "Allow less secure apps:" to "ON"
6) I then log out of my gmail account, and reboot.

RESULTS:
Sylpheed can send email. But Sylpheed still can't get mail from my gmail. This wouldn't have to do with all the labels and filters that I have set in gmail, would it?


What am I doing wrong?

Last edited by andrew.comly; 05-29-2015 at 07:51 PM. Reason: FORGOT tags
 
Old 05-29-2015, 08:08 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 16,685
Blog Entries: 27

Rep: Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065Reputation: 5065
The only idea I have is to start Sylpheed from the command line. Perhaps it will throw some error messages to the terminal that might cast some light on this. This link tells me that Sylpheed maintains a log file at $HOME/.sylpheed/sylpheed.log. You might also look in there.

(When I've set up mail clients, if I have problems, it's usually sending, not receiving.)
 
1 members found this post helpful.
Old 05-29-2015, 09:09 PM   #3
andrew.comly
Member
 
Registered: Dec 2012
Distribution: Trisquel-Mini 7.0, Lubuntu 14.04, Debian lxde 8.0
Posts: 308

Original Poster
Blog Entries: 2

Rep: Reputation: 16
~/.sylpheed/sylpheed.log contents:
[10:03:26] fcitx-connection-DEBUG: _fcitx_connection_connection_finished
[10:03:26] fcitx-connection-DEBUG: _fcitx_connection_connection_finished
[10:03:26] fcitx-connection-DEBUG: _fcitx_connection_connection_finished
[10:03:26] fcitx-connection-DEBUG: _fcitx_connection_connection_finished
[10:03:27] ** LibSylph-CRITICAL: folder_item_get_uncached_msg_list: assertion 'item != NULL' failed
[10:03:27] ** Sylpheed-CRITICAL: folderview_check_new_item: assertion 'item != NULL' failed
[10:03:47] ** LibSylph-CRITICAL: folder_item_get_uncached_msg_list: assertion 'item != NULL' failed
[10:03:47] ** Sylpheed-CRITICAL: folderview_check_new_item: assertion 'item != NULL' failed
[10:03:47] ** LibSylph-CRITICAL: folder_item_get_uncached_msg_list: assertion 'item != NULL' failed
[10:03:47] ** Sylpheed-CRITICAL: folderview_check_new_item: assertion 'item != NULL' failed
 
Old 05-29-2015, 09:12 PM   #4
dolphin_oracle
MX Linux
 
Registered: Dec 2013
Posts: 402

Rep: Reputation: Disabled
silly question: did you enable imap access in your gmail settings? its off by default.
 
1 members found this post helpful.
Old 05-29-2015, 09:38 PM   #5
andrew.comly
Member
 
Registered: Dec 2012
Distribution: Trisquel-Mini 7.0, Lubuntu 14.04, Debian lxde 8.0
Posts: 308

Original Poster
Blog Entries: 2

Rep: Reputation: 16
Smile it was originally enabled

Quote:
Originally Posted by dolphin_oracle View Post
question: did you enable imap access in your gmail settings? its off by default.
Yes, it was already enabled:
Gmail > settings > Forwarding and POP/IMAP > > IMAP Access: 1. Status: > enabled

thanks anyway.
 
Old 05-29-2015, 09:43 PM   #6
dolphin_oracle
MX Linux
 
Registered: Dec 2013
Posts: 402

Rep: Reputation: Disabled
so its not something simple.

Quote:
I have used the following procedure to set up a gmail account from sylpheed 3.4.1, but as a result I can only send email, and not receive email. Even though I am using lubuntu 14.04, still in the future I would like to use debian. Thus sylpheed is the choice email client.
there is also icedove in debian, which is the debianized version of mozilla thunderbird, in case you decide to try a different client.
 
1 members found this post helpful.
Old 05-29-2015, 10:14 PM   #7
mralk3
Senior Member
 
Registered: May 2015
Distribution: Slackware, OpenBSD
Posts: 1,466

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Quote:
Originally Posted by dolphin_oracle View Post
silly question: did you enable imap access in your gmail settings? its off by default.
Just in case, enable IMAP in Gmail: https://support.google.com/mail/answ...95?topic=13294
 
Old 05-30-2015, 10:28 PM   #8
andrew.comly
Member
 
Registered: Dec 2012
Distribution: Trisquel-Mini 7.0, Lubuntu 14.04, Debian lxde 8.0
Posts: 308

Original Poster
Blog Entries: 2

Rep: Reputation: 16
[Solved]
I deleted the account and then created a new gmail account, but with the following changes:
Code:
Start Sylpheed
Configuration   >   Create new account ...   >   IMAP4 (just regular imap4, not 'imap4 gmail').

imap4 server: 			imap.googlemail.com:993 (SSL)  //[Not imap.gmail.com]
smtp4 server: 			smtp.googlemail.com:465 (SSL)
Besides this, everything was the same. Here are my acct preferences:
Code:
BASIC
Name acct:  			GMail
Full Name:  			a
Mail addr:  			youremail@gmail.com
Organization:		

Serv Inf 
Protocol:			IMAP4
Server for receiving:		imap.googlemail.com
SMTP server (send):		smtp.googlemail.com
User ID: 			youremail@gmail.com
Password:			fill in your passwd

RECEIVE
IMAP4
Auth method:				Automatic
'Get all' checks for new 
messages on this acct  			[Check this]

SEND
Header
Add Date header file:			[check this]
Generate Message-ID:			[check this]
Authorization
SMTP Auth (SMTP AUTH)			[check this]
Authentication method			Automatic
User ID: 				youremail@gmail.com
Password:				fill in your passwd

COMPOSE
Signature
Direct Input				[check this]
[your email address should be here]
[everything else unchecked]

PRIVACY
Check the following:
1) Encrypt when replying to encrypted message
2) Add my own key to the recipients list on encryption
3) Use default GnuPG key
[everything else unchecked]

SSL
IMAP4
Use SSL for IMAP4 connection		[check this]

Send(SMTP)
Use SSL for SMTP connection		[check this]

Use non-blocking SSL			[check this]

PROXY
[everything unchecked]

ADVANCED
Specify SMTP port  			465
Specify IMAP4 port  			993
[everything else unchecked/blank]
The original problem is solved, but one thing that really is quite embarassing for both sylpheed (and thunderbird) is that no one at these two companies EVER thought to differentiate between the concept of 'deleting' and 'un-downloading'. 'Deleting' is when you delete email from an imap account, and both local email and server(real) email are deleted. 'Un-downloading' is merely the user removing email from the local cache. This is necessary due to older email bloating up your folders. I will probably post a new thread about this.

Of course the two terms I've used above aren't very elegant, but I'm sure you can get the idea.

Thanks everyone!

Last edited by andrew.comly; 05-30-2015 at 11:50 PM.
 
  


Reply

Tags
email, filter, gmail, receive, sylpheed


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Can send and receive plain text mail, but can't receive on html pravada Linux - Server 6 05-20-2013 03:25 PM
[SOLVED] Can send and receive plain text mail, but can't receive on html pravada Linux - Software 1 05-17-2013 03:13 PM
Postfix : mail cannot send to send outside ( can send/receive locally) bobbinsupport Linux - Networking 3 12-15-2007 10:40 PM
Server does'nt send mail until shutdown and LAN can't send or receive. Wolfy Linux - Networking 0 08-02-2004 07:31 PM
Can't send e-mail with Sylpheed tk7967 Linux - Software 10 03-05-2004 06:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration