-   Linux - Software (
-   -   switching from xorg to xfree86 in debian (

kramtoad 07-05-2006 11:09 PM

switching from xorg to xfree86 in debian

I'm having some major problems with xorg. Afterstep crashes shortly after starting with what appears to be radeo related problems. Afterstep worked fine until i did a refresh at which point X crashed and won't restart. I've had some other problems that I think are xorg related so I'd like to switch back to xfree86. Is there a simple way to do that in debian?

I messed with apt-get but didn't have any luck.

thanks much for any help.


rickh 07-05-2006 11:17 PM

Can't imagine a good reason to do that, but ... I'd try apt-get remove --purge xorg ... then change your sources list to stable, and do apt-get install x-windows-system.

I think you're going to run into major problems. Would probably be better to reinstall Sarge from scratch leaving /home intact. Of course that assumes that you have /home on a separate partition. Everybody should.

kramtoad 07-06-2006 09:03 AM

some additional info
Reinstalling is the LAST thing I want to do!

In the X startup messages I get:

RADEON no matching device section foor instance (busid pci:1:0:1) found(**) radeo(0): radenpreinit

But the device section is there and X was working fine (haven't touched the config file since installing it.)

I also get the message:

RADEON(0): [agp] failed to initialize. Disabling the DRI.

Does that mean that there is simply no 3D graphics or is it something worse? For all I know I've been getting these messages all along and the problem is elsewhere.


kramtoad 07-06-2006 10:20 AM

another updatehmmmm....
hmmmmm.... I remove afterstep and reinstalled it. Problem solved, at least for now. When starting X (xorg still installed) an afterstep seg fault occured (didn't happen at every restart, though) so maybe this whole thing is an afterstp problem. <sigh>


All times are GMT -5. The time now is 10:41 PM.