LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Switch to X.org from Xfree86 HOWTO? (https://www.linuxquestions.org/questions/linux-software-2/switch-to-x-org-from-xfree86-howto-304315/)

Napalm Llama 03-21-2005 10:57 AM

Switch to X.org from Xfree86 HOWTO?
 
I use SuSE 9.1 Personal, and I've decided that if possible, I'd like to use X.org - it seems better.

I can't upgrade to 9.2 (which I understand has it as default) just yet.

Does anybody know how it could be done?

__J 03-21-2005 11:31 AM

either try to find a 9.1 package, or build it from source. it's a straight forward build process, just follow the BUILD instructions located in the source directory. note that with your distro, you will need libpng-devel and fontconfig-devel ( or fontconfig too if you do not already have it).

also note that there isn't much difference between the two yet (xfree-4.4-rc1 and Xorg-6.x), there are a few, but not many.

tommyj27 03-21-2005 11:37 AM

if you're planning to upgrade suse in the near future and you don't have a specific need for x.org over XFree, i'd leave well enough alone.

Napalm Llama 03-21-2005 11:48 AM

I was hoping I guess that it might fix my X crasahing problem.

When I use the nvidia driver, X crashes and I have to do a reset, which I really don't like.

So now I'm stuck on nv, with no 3D to speak of and no tasty tasty alpha:mad:

tommyj27 03-21-2005 11:55 AM

have you tried googling your problem? i'm more familiar with ATI issues myself but there's probably an answer out there somewhere. have you checked your Xfree86 logs? the problem might be right there, look in /var/logs/ there should be some log files.

__J 03-21-2005 12:01 PM

what version of the nvidia driver are you trying? they seem to be hardware dependent, what works for one might not work for another. I had endless problems with the 66 version driver, but 6111 and the newest work good.

Napalm Llama 03-21-2005 12:45 PM

I don't know - how do I find out?

lspci gives me this:
Code:

0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)
What am I looking for in /var/log? The problems were a little while ago now (I haven't tried fixing them again since) and I don't know if the logfiles have been overwritten...

__J 03-21-2005 01:20 PM

check /var/log and see if there is a file called "nvidia-installer.log" inside. down toward the bottom of that file will be a version number ( it will say something like " installation of nvidia driver 1.0-x.xxx.xxxxx is complete).

Komakino 03-21-2005 01:34 PM

Use a high number 5 series nvidia driver...the one before release 6111. I set up X on a friend's computer with the same card and that was the one that worked best

tommyj27 03-21-2005 01:39 PM

the Xfree logs get overwritten every time you start it, so to glean any info from them you'd have to recreate the problem.

Napalm Llama 03-21-2005 02:17 PM

OK then.

Tell me what logfiles are needed, and I'll copy them to a safe place before restarting X.

Hey, do you know how to set a timeout in a shell script? I suspect that the system is still OK underneath, but because X steals all the input devices, when it crashes you're stuck.

I'm thinking something along the lines of
Code:

#!/bin/sh
xinit
wait 30 -c "kill 12345"

Where 12345 is the PID of X, and there's no way of knowing that until X starts...

But do you see what I mean?

Could that be done?

tommyj27 03-21-2005 02:23 PM

what you're looking for is 'sleep'. IIRC X starts more than one process, so you may want to sort out which processes are started and issue some 'killall -9 xyz' commands

if you have another networked machine you can login from you can kill things that way. you're probably right in assuming the system is still responsive, that's usually how it was for me.

Napalm Llama 03-21-2005 03:54 PM

I do apologise - I'm really not that familiar with cmds that I don't use every day.

You couldn't explain what that killall does, could you?

There's still a bit of a newbie in everyone, right?;)


Heh, see if I can get my old old FreeBSD box working again... that might just do the job...

tommyj27 03-21-2005 04:04 PM

killall kills all occurances of the process specified by name, for example.

# killall crond

would kill all running procs named 'crond'. the -9 tells killall to kill with signal 9, a no-nonsense kill signal. i would check out the killall man page 'man killall'. also be aware that killall functions differently between flavors of *nix. IIRC, solaris killall kills every process on the machine.

don't be ashamed of being a newbie, anyone who says they never were is a liar. just make sure you do research on your problem first and ask questions as clearly as possible. the man pages are your source of info for almost any command. just type 'man xyzcommand', google is your best friend too.

if you can get a working freebsd box you can use it to log in using ssh. even if you have a windows box, google PuTTY, it's a ssh client.

Napalm Llama 03-21-2005 04:43 PM

Yup, I had PuTTY on my Windoze boxes before I dolloped a healthy helping of penguin across 'em:D

I've reached my BSD box now, it seems to be working OK (touch wood) but it won't accept my password... I must have the encoding set wrong or something...

I don't really consider myself that much of a newbie anymore, but like I said, I'm only good now at the bits I use - for things I haven't done before (like formatting a floppy the other day:rolleyes: ) I may as well have only started yesterday...


All times are GMT -5. The time now is 01:08 AM.