LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-07-2004, 11:54 AM   #1
iain.ross
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: SuSE 9.2 Pro, KDE 3.4
Posts: 82

Rep: Reputation: 15
SuSE 9.1 Kmenu troubles


When I edit the Kmenu by right clicking the menu button and slelecting edit kmenu, I find that certain submenus are not expanding. I want to delete an icon in just such a submenu.

Is there a way to edit the Kmenu from a command line terminal?

Thanks

Anyone?? I've googled without much luck...

Last edited by iain.ross; 08-08-2004 at 11:54 AM.
 
Old 08-08-2004, 11:54 AM   #2
iain.ross
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: SuSE 9.2 Pro, KDE 3.4
Posts: 82

Original Poster
Rep: Reputation: 15
Bump
 
Old 10-20-2004, 04:45 PM   #3
Zhenya
Member
 
Registered: Sep 2004
Location: Maryland, USA
Distribution: Suse 9.3 Pro
Posts: 92

Rep: Reputation: 15
Have you solved your problem? If yes, maybe you can share it with me (as well as many others). :-)
 
Old 11-13-2004, 02:40 PM   #4
PredatorX
Member
 
Registered: Sep 2003
Location: The Hague
Distribution: Gentoo / Suse 9.2
Posts: 53

Rep: Reputation: 15
Same problem here. Emerges after making manuel changes it seems.
I did not have these problems with kde 3.3.
Als so removing the .kde dir works, but is not very elegant, because all entries are fuct.
I am also very open to a solution!
 
Old 12-05-2004, 08:57 PM   #5
thegsusfreek
Member
 
Registered: Jul 2004
Posts: 34

Rep: Reputation: 15
Only thing I've found to do is to go to the ~/.config/menus/ folder and delete the kmenu file there. Then, any edits you want to make need to be made all at once with the menu editor because once you save the changes and close the editor, when you open it back up it won't show up correctly. Another thing I've noticed is that it appears that I can't permanently delete kmenu items. I can only hide them.

I didn't notice this before I performed a YOU update. Perhaps something that I updated ruined this? I've been searching for weeks now trying to get this solved. Let me know if you come up with anything better.
 
Old 12-06-2004, 07:26 AM   #6
PredatorX
Member
 
Registered: Sep 2003
Location: The Hague
Distribution: Gentoo / Suse 9.2
Posts: 53

Rep: Reputation: 15
Thanks for your reply. I don't think this is a solution, since every time you add something, you have to add all the other things too, if following your procedure.
This bug plain sucks in my opinion.

I also noticed the non-vanashing things. It seems there is a standard set of entries. Then if you add an entry to one of those, it will become visible.
I noticed that if you add on ly 1 item it will be in the list directly and when adding more it makes another subfolder.
I think that is not too bad, but for example for the integrated environment link i have two links.
When I remove 1, both are gone!
That is in KDE 3.3.0 and 3.3.1 . I think they should let manual intervention overrule.
Hope they will fix this. Now I am typing on Gentoo and there are no subfolders for double items.
Maybe it is a feature Suse added?

If somebody finds out, a bug report might be usefull.

 
Old 12-06-2004, 09:34 AM   #7
thegsusfreek
Member
 
Registered: Jul 2004
Posts: 34

Rep: Reputation: 15
Yes. This bug stinks. Lots of people are having trouble with similar kinds of things. I hope they fix it soon.
 
Old 12-06-2004, 10:31 AM   #8
iain.ross
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: SuSE 9.2 Pro, KDE 3.4
Posts: 82

Original Poster
Rep: Reputation: 15
Ive not had any trouble after upgrading to KDE 3.3.1

I'm now running SuSE 9.2 Pro BTW
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 10 KMenu Search annoyance thesraid SUSE / openSUSE 10 10-27-2005 12:35 PM
[Suse] Installation Troubles Warder Linux - Distributions 1 09-27-2005 06:09 AM
KDE 3.4 on SuSE 9.3 refuses to change KMenu icon joe_huddleston Linux - Software 2 06-05-2005 02:14 AM
Troubles with SuSe 9.1 firefork Linux - Newbie 4 04-24-2005 08:26 PM
SuSE Modem troubles hindenbergbaby Linux - Newbie 5 09-17-2003 04:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration