LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-29-2004, 06:54 PM   #1
MrFubar
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.1
Posts: 18

Rep: Reputation: 0
Question SuSE 9.1 -- Installing RPMs in YaST


I just got SuSE 9.1 installed, and I am having a problem installing RPM packages with yast. when i click on an rpm file in konqueror i can then select the option "install package with yast", but when i do that, yast only loads the packages available on the installation cd. i added my downloads folder as a directory in yast to check for when i install packages, but it still cant find the files. Is there something I'm doing wrong or forgetting to do when I try to install rpms? Any help would be greatly appreciated!
 
Old 05-29-2004, 11:15 PM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Actually, there should be several alternatives you can pick from:

1. You can probably install directly from YaST ... but frankly, I ran into
exactly the same problem you did, and I don't install RPMs often enough
that I ever bothered to figure it out.

2. You can use the "RPM" command directly from the command line.

3. You can go into the GUI file browser (konqueror) and double-click on
your RPM (or compressed RPM). The system should "do the right thing".

Good luck .. PSM
 
Old 05-29-2004, 11:34 PM   #3
critch
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
I too ran into this problem with SuSE 9.1. At first I thought there was a good reason why YaST would not install... like the i585 rpm was not compatible with my AMD64 distro. But I became confused when even the i386's were kicked out.

Perhaps rpms which lack certain security features are not accepted? This is a great question for the SuSE forum (http://forums.suselinuxsupport.de/).

For these packages I simply install with "Kpackage" which is a default option that appears in Konqueror when you select the rpm with your right mouse button.
 
Old 05-30-2004, 12:04 AM   #4
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Try konqueror...

But again, please try double-clicking on your RPM with the GUI file explorer (konqueror). That should probably work for you.

Good luck .. PSM
 
Old 05-30-2004, 12:17 AM   #5
critch
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
Paul,

Double-clicking will not work.

All double clicking does is bring up YaST (or more exactly the option to run YaST)... If you continue with YaST it decides that it likes the CD versions of the rpm better and uses them instead (without asking or telling you that it is doing so). This is in the original poster's message. TFP.

Kpackage will let you do what you need without having to read the man pages for rpm.
 
Old 05-30-2004, 12:57 AM   #6
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
With all due respect, what you're saying about double-clicking is *not* true. You *can* install from YasT - but I honestly don't recall the details of how to do it.

And it doesn't matter ...

... because your advice about KPackage is absolutely correct. That is indeed the solution to his problem.

One can run "kpackage" from the command line ("kpackage &"), or from the "Applications, system, configuration" KDE menu option.
 
Old 05-30-2004, 05:22 AM   #7
Rudwardt
LQ Newbie
 
Registered: May 2004
Location: Germany
Distribution: Debian
Posts: 22

Rep: Reputation: 15
IIRC you need a file called packages or something alike, which lists the rpms and their contents. Yast will look for this file (check out your CDs, there should be one) in the directory with the rpms.
If you have installed SuSE-Extensions for Konqueror or Kpackage - I don't remember which, you should have an Option in your Konqueror contextmenu which generates this file.
You will also have a little script (sorry - again I don't remember the name - but you'll find it if you search a little) which generates packages files for directorys containing rpms.

But I agree that for the occasional rpm Kpackage is the easiest way.
__
Rud
 
Old 05-30-2004, 09:24 AM   #8
critch
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.1
Posts: 15

Rep: Reputation: 0
Paul,

I don't doubt that you *can* install from YaST. But the fact remains that the default configuration of YaST does not allow myself or MrFubar to view or install some RPMs. I'd like to know how to change these settings and maybe even learn why they are this way to begin with.

As for double clicking:
1). In a default SuSE install there is no such thing as a double click in Konqueror. I believe "single-click to open files (and folders)" is enabled.
2.) We all customize our interfaces differently... I set mine to use double-clicks instead because I like to select files with single click.

What double click behavior do you have that in SuSE 9.1 Konqueror does not bring up a page with a button which says "install with YaST"? This is effectively what MrFubar said in his first message.

I don't understand. How am I wrong about double-clicking?
 
Old 05-30-2004, 12:16 PM   #9
ultrabeam16
LQ Newbie
 
Registered: Mar 2004
Distribution: Debian Sarge
Posts: 7

Rep: Reputation: 0
It is easy to install with YaST... To do it you simply double-click the RPM file (in konqueror) and click "Install package with YaST". The only restriction is that the path where the package is stored CANNOT have ANY SPACES.

So if the package is stored at "~/rpm packages/mypackage-1.1.1.rpm" then YaST won't install it, it will just come up with the package search screen. If thats the case just move the RPM to a path with no spaces in it or just rename the "rpm packages" directory to have no spaces, eg. to "rpm_packages" so you have a path of "~/rpm_packages/mypackage-1.1.1.rpm".

Remember you can't have any spaces in the RPM package file name either.

Hope that helps

Last edited by ultrabeam16; 05-30-2004 at 12:18 PM.
 
Old 05-30-2004, 03:46 PM   #10
MrFubar
LQ Newbie
 
Registered: May 2004
Distribution: SuSE 9.1
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the replies everyone! I actually ran YOU yesterday and noticed that there was a new patch that fixed problems with YaST installing RPMs, so it works fine now, but I think im still gonna check out kpackage anyways since it sounds a lot easier and more stable.

Also I did try moving an rpm to a folder with a space in the name (just out of curiosity) and you were right ultrabeam, it didnt like it. That may have been my problem before because I installed Firefox and it created a "My Downloads" folder in my home folder to save the files to. So just a heads up if anyone else installed firefox and is downloading files to Firefox's default download folder...

Thanks again for the replies everyone!

Last edited by MrFubar; 05-30-2004 at 03:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
In SuSE 9.1, YaST installs old RPMs kshaffer SUSE / openSUSE 2 11-22-2004 06:49 PM
Suse 9.1 Pro problems with yast installing rpms fight_the_$oft SUSE / openSUSE 4 11-20-2004 10:01 PM
Installing S/W from DVD using YaST (Suse 9.1 Pro) xian67 Linux - Distributions 1 07-30-2004 04:02 PM
Problems installing RPMs in suse linux 9.0 jginger Linux - Newbie 3 07-27-2004 03:13 PM
Installing RPMs on Suse 9.1 inline.skater Linux - Distributions 7 06-28-2004 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration