-   Linux - Software (
-   -   Suse 9.1; k3b; cdrecord; cdda2wav PROBLEM. (

pepeq 10-18-2004 10:47 AM

Suse 9.1; k3b; cdrecord; cdda2wav PROBLEM.

AMD Athlon XP 2000
256 Mb Memory
Suse 9.1
kernel default
kde 3.3.0
k3b-0.11.17-3suse91.i686.rpm & devel &devel

1.- I cannot do audio CD copies using normal mode in k3b, because songs get extrange noises, although the copy itself does perform. I have studied the problem and I think it is because the wav files created to do the copy get some kind of corruption. Maybe cdda2wav problem?
2.- I cannot do audio CD copies using clone mode unless I use the option to only create the image and afterwards burn the image in another process. However, the image created is often too big for a 700 Mb CD-R, even when I am copying from a CD copy originally burnt into a 650 Mb CD-R! This is very extrange for me.

I think that I didn't have those problems when I had the original configuration os Suse 9.1, nevertheless, I tried to go back to original kernel, k3b, cdrecord, cdda2wav and it did NOT solve the problem.

Researching into the problem I knew that Suse linux does not use the original versions of cdrecord and cdda2wav, so I seeked the original ones. I was pointed to the cdrtools 2.01. However, I didn't find a rpm with it and I was unable to compile it in my system. To compile I used: first GNU make -no success-, then I installed the smake rpm and tried with it -no success either-. I've read the documentation of cdrtools and although I AM A NEWBYE, I think I followed the instructions. In both cases -make or smake- the compilation seems to finish (after the make install or smake install, of course). But then if I try to use cdrecord in the Konsole I am told that "bash: cdrecord: command not found". I don't understand anything. Why is linux so difficult?

Could any of you help me?
I would thank easy language.

Thanks in advance!!!

cippo 10-18-2004 11:06 AM

I ripp the CDs with konqueror first (audiocd:/ in addressline) and then I figure the CDs with k3b > new audio-project manualy. If there is enough space, I will fill it with songs of another CD. So I use allways the whole space of a CD-R. With the copying-function of k3b I had problems, too.


pepeq 10-18-2004 02:43 PM

I have considered that possibility yet, but it is not very elegant and/or quick. Thank you a lot anyway.

But nobody has found the way that k3b works completely OK? Am I the only one -or almost- with those permanent problems?

mikedeatworld 10-18-2004 03:21 PM

You could:

run k3b as root, this will allow for allowing burning, ripping, etc of CD's


run YaST and update all packages recommended, included the one that say universal cd recording software (something like that).

pepeq 10-18-2004 07:13 PM

Hi again.

-According to my first message at this forum,, I have found a way to solve the PROBLEM Nš1: In advanced options -normal mode-, I had paranoia mode 0. Now, if I use a diferent mode (1,2,3) there are no extrange noises at the copied Audio CD. Will I have quality loss using paranoia? Which mode is good enough taking into account speed-quality?

-However (let's call this PROBLEM Nš 3), in normal mode I must not choose ON THE FLY. Otherwise, COPY IS VERY SLOW. I use a CDROM 52X and a CDRECORDER 44x, and in Winblows XP it works quite good. Any ideas?

-About PROBLEM Nš2, in clone mode, if I try to burn the image sometimes it get burnt, but then the system will not recognize the copy as an Audio CD, and though a DiscMan will play it, only the first songs are ok, but the folowing ones are corrupted.


pepeq 10-20-2004 02:33 PM

Partial solution.

Today I have updated the kernel to 2.6.5-7.111 through YaST and PROBLEM 1 and 3 have just dissapeared.

About PROBLEM 2 -clone mode- the Audio CD get completely cloned, and the are recognized by a normal Diskman, with no errors in the songs. THE ONLY EXISTING PROBLEM now is that no program will recognize the Audio CD in the computer.

Any ideas?


All times are GMT -5. The time now is 12:59 PM.